locked
WP8 SDK app deployment to emulator does not work RRS feed

  • Question

  • Hi,

    i've ran in an strange error. I've installed the WP8 SDK on Windows 8 Pro x64.

    If i try to deploy an app to the emulator, Visual Studio throw's an error:

    "A specified communication resource (port) is already in use by another application"

    Any idea what program could cause this?

    Thanks in advandce!

    Tuesday, October 30, 2012 11:23 PM

All replies

  • Did you deploy 7.5 Application or 8.0 Application? Which Emulator? Just to understand if this is coming in Hyper-V emulator or normal Emulator of 7.5

    Are you still getting this error or was it one of case when you first time deployed basic project?

    Wednesday, October 31, 2012 3:21 AM
  • Same error.

    7.1 apps can be correctly deployed and work on 7.1 emulators (both).
    But, if I try to debug any project on any 8.0 emulator, it deploys but launching TaskHost.exe leads to error specified above.

    Also, when I try to open emulator tab with tools (location, screenshot ...)  I receive error:

    “cannot find  …/Appdata/local/temp/ ..” Same error when click on “Refresh” button it Network tab.

    Wednesday, October 31, 2012 7:03 AM
  • Yes i can confirm this. The 7.1 emulator seems to just work fine. The problem occurs to be related to the 8.0 emulator.

    After trying some things, i've realized that the problem seems to be my project. Because if i create a new project both emulators just work fine. Also after i got a new working copy of my project an upgraded it again, every worked just fine. So i guess my problem are solved magically...

    @Maxim Morzhov: Did you try to repair the SDK 8.0 installation? It seems to me that there is something not installed right.

    Wednesday, October 31, 2012 12:14 PM
  • @Matthias Baur:

    What I've try:

    1. repair SDK installation
    2. create empty projects (7.1 and 8.0)
    3. delete content in folder ..\AppData\Local\Microsoft\Phone Tools\CoreCon
    4. restart Hyper-V service

    What I've got:

    Deploying successful. Launching TaskHost.exe results in error "A specified communication resource (port) is already in use by another application"

    Deployed apps can be started in emulator manually (no debugging).

    UPDATE:

    If using Blend, I can deploy and run any app in any WP 8.0 emulator.
    So, problem may be with MSVS 2012 Premium installation.

    Second error, occurring when pressing "Refresh" button, may be due localization.
    I use Russian Win 8 Pro with English versions of VS 2012 Premium and WP 8.0 SDK. It seems, that it can't find file with network settings, because of using Russian characters in full folder path.  

    Wednesday, October 31, 2012 1:03 PM
  • Got a similar problem here.

    While deploying the app, the emulator windows shows up and says "The Windows Phone OS is starting..." - then nothing happens. I can close the window, the message changes to "The Windows Phone Emulator is shutting down". In other words, I'm unable to emulate a WP8 app.

    My hardware :

    Acer Aspire 7750G, Core i5, 4GB , Bios is a modified v 1.17 to allow access to VT functions, all are enabled.

    CoreInfo.exe -v result says :

    • Hypervisor * Hypervisor is present
    • VMX - Supports Intel hardware-assisted virtualization
    • EPT - Supports Intel extended page tables (SLAT)

    Last minute observation :

    There's also a "Invalid pointer" error in VS2012 after the modal window saying that the deployment has failed.


    Maciek


    Wednesday, October 31, 2012 2:27 PM
  • Hi Maciek,

    I am experiencing the same exact problem.  I am also running Windows 8 Pro with VS2012 Premium. The emulator says it is starting, but then nothing.

    I've tried repairing the install, and still does not solve the problem.

    Wednesday, October 31, 2012 4:20 PM
  • Can you try simply deploying the app(Ctrl+F5) instead of debug(F5) and tell if that works?

    Are you not able to deploy a simple app even once on emulator after installation? Make sure you do not have any other instance of VS connected to emulator. Also do a clean rebuild before deploying.

    Saturday, November 3, 2012 8:33 AM
  • You should wait while emulator is coming up. Do not kill it yourself. Emulator can take some time depending on machine config.

    Saturday, November 3, 2012 8:35 AM
  • @Matthias Baur

    hi

    if you try to debug a second app on the same 8.0 emulator while another debugging session is going on, then the error you got is expected. This is not the case for 7.1 emulators.

    please let me know if this is the case.

    Regards

    Rahul

    • Proposed as answer by pmyn Tuesday, April 15, 2014 8:40 AM
    Tuesday, November 6, 2012 4:34 PM
  • I found the solution for this. In my case the problem was in my account name using non-Latin letters. I followed this guide to rename my account folder.
    Saturday, November 24, 2012 9:51 AM
  • Project GUID conflict

    Yet another possible reason for this error is the Project GUID conflict. If the project / app GUID of the application you are trying to debug is the same as the GUID of another application installed from the store (can be the same application, and doesn't matter if you already uninstalled it), this error may occur.

    I was testing in-app purchases for my app for which purpose I had to change the app GUID in WMAppManifest.xml and AssemblyInfo.cs to the GUID from the Windows Phone Store. Having the app installed from the store itself (for testing purposes) previously, I uninstalled it for the purpose of debugging. Yet that didn't help and anytime I changed my app GUID to match Windows Store App Guid I got this error. Changing the GUID back to the original project's GUID caused the error to go away and debugging was working well again.

    VS2013 Ultimate Update 2, testing with 8.1 Device.

    Monday, June 9, 2014 1:29 PM