none
Event 10016 RRS feed

  • Question

  • On a Windows 2008 R2 server running SQL Server 2012, I started getting these recently:

    SQL Server Scheduled Job 'Intraday Backup 1500.Subplan_1' (0x65C01B2C6FA5124493CA18E3665B09AA) - Status: Failed - Invoked on: 2012-09-10 16:18:58 - Message: The job failed.  Unable to determine if the owner (<DOMAIN>\administrator) of job Intraday Backup 1500.Subplan_1 has server access (reason: Could not obtain information about Windows NT group/user '<DOMAIN>\administrator', error code 0x6e. [SQLSTATE 42000] (Error 15404)).

    After some research it seemed that I should change the owner of the job to something else, so I made it SQLServerAgent, that seemed to be the only thing that worked.

    Now I'm getting these:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
    {FDC3723D-1588-4BA3-92D4-42C430735D7D}
     and APPID 
    {83B33982-693D-4824-B42E-7196AE61BB05}
     to the user NT SERVICE\SQLSERVERAGENT SID (S-1-5-80-355555556-2666666661-2777777773-2888888883-1999999990) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    I did my usual digging around and couldn't find much that was useful, apart from notes about locating the appid mentioned in the registry and going to Component Services to fix the permissions.  The appid translates to MS DTS Server, nothing like that is listed in DCOM.



    I've done a fair bit of searching and reading and got nowhere with this, maybe I'm missing the point.  The job does run now, I'm just averse to errors in the Event Log, I mean they wouldn't be there if it didn't matter, would they?


    • Moved by Papy Normand Wednesday, September 19, 2012 3:07 PM related to the Database Engine (From:SQL Server Data Access)
    Monday, September 10, 2012 3:46 PM

Answers

  • Posted by iain27 on 3/10/2009 at 11:37 AM

    – open com permissions
        Component services, computers, my computer, 
    DCOM config, find the MSDTSServer100 
    Properties
        Security
        Launch and Activate permissions – edit
    Add the local SQL AgentUser group and enable local launch and Local activation

    I think translates to:

    Open Component Services, Computers, My Computer, DCOM Config, find Microsoft SQL Server Integration Services 11.0
    Properties
        Security
        Launch and Activate permissions – edit
    Add the local SQLServerAgent and enable Local Launch and Local Activation

    I'll let you know if it works.


    Fixed!  :)

    Wednesday, September 19, 2012 3:57 PM

All replies

  • Hello,

    This thread is not related to SQL Server Data Access. I am trying to find a better forum.

    Have a nice day


    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.

    Monday, September 10, 2012 9:43 PM
  • Tuesday, September 11, 2012 12:47 AM
    Moderator
  • As I've explained, "find the MSDTSServer100" is no help, it isn't there.
    Tuesday, September 11, 2012 8:42 AM
  • In SQL 2012, the COM object is called "Microsoft SQL Server Integration Services 11.0", instead of "MSDTSServer100".

    Tuesday, September 11, 2012 1:41 PM
    Moderator
  • It would help if they stopped changing the names of everything all the time.

    Now I've found that, what is the "local SQL Agent User group"?

    Tuesday, September 18, 2012 3:06 PM
  • Hello,

    http://msdn.microsoft.com/en-US/library/ms143691(v=SQL.90).aspx

    or :

    http://social.msdn.microsoft.com/search/en-us?query=local%20SQL%20Agent%20User%20group&ac=8

    Have a nice day


    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.

    Tuesday, September 18, 2012 5:49 PM
  • Hello,

    I will follow the Tom's advice.I am moving your thread towards the Database Engine forum.

    I hope you will have a quick and full answer in this new forum.

    Have a nice day


    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.

    Wednesday, September 19, 2012 3:05 PM
  • Posted by iain27 on 3/10/2009 at 11:37 AM

    – open com permissions
        Component services, computers, my computer, 
    DCOM config, find the MSDTSServer100 
    Properties
        Security
        Launch and Activate permissions – edit
    Add the local SQL AgentUser group and enable local launch and Local activation

    I think translates to:

    Open Component Services, Computers, My Computer, DCOM Config, find Microsoft SQL Server Integration Services 11.0
    Properties
        Security
        Launch and Activate permissions – edit
    Add the local SQLServerAgent and enable Local Launch and Local Activation

    I'll let you know if it works.


    Fixed!  :)

    Wednesday, September 19, 2012 3:57 PM
  • Hello,

    It is nice to write "Posted by iain27  on 3/10/2009 at 11:37 AM". But i have found nothing about iain27 for this date.

    Please, could you give the link related to the iain's post ?

    Have a nice day


    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.

    Thursday, September 20, 2012 1:37 PM
  • Just what I needed, thank you. That was the right name for 2012. You need to add whatever user or group you use to run SQL Server Agent and/or the Engine. You aren't running SQL as the default user are you?
    Thursday, January 16, 2014 6:49 PM
  • FIXED - This fixed my problem on SQL2012/W2012.  The only trick is to add the local user "NT Service\SQLServerAgent".
    Friday, October 31, 2014 3:16 PM
  • So far this isn't working for me.   I'm still getting the error.  I added the SQLServerAgent to the domain, within the Component Service  Microsoft Sql Server Integration Services 13.0   

    I assigned local launch/local activation permissions  and Access permissions. 

    But I'm running on a remote virtual server hosted in a data center.  A different post suggested this must be done on the Local machine. But I haven't the option/permissions to change anything to local machine so it has to be on the domain to which it belongs. Does that make sense to y'all? 

    UPDATE: 

    2 hours since this error has been logged. So my last run through this to attempt to assign more permissions must've resolved this. Historically it has been happening every hour. Thanks!

    Thursday, January 17, 2019 3:43 PM