none
SimplePageHeader property in SSRS 2008 not working RRS feed

  • Question

  • Hi I am working with SSRS 2008 and i have no service packs for SSRS 2008 installed. When I export the reports to excel I will have to display the Header in the Header section of the Excel.So I set the SimplePageHeader property to True in rereportserver.config and restarted the reporting services and an IISreset. But the changes are not reflecting. What should I do?? Doesn't SSRS 2008 support SimplePageHeader??
    Friday, July 15, 2011 4:38 AM

Answers

  • Hi Malahaxmi,

    In Reporting Services, the “SimplePageHeaders” setting indicates whether the page header of the report is rendered to the Excel page header. The default value is “FALSE” and it indicates that the page header is rendered to the first row of the worksheet.

    In order to display the page header in the Header/Footer section of Excel, we need to set the “SimplePageHeaders” setting value to “TRUE”. I did a test on my local machine here are my steps:
    1. Navigate to RSReportserver.config file: <drive:> Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\RSReportserver.config.
    2. Backup the RSReportserver.config file before modify it, open the RSReportserver.config file with Notepad format.
    3. Set the Excel rendering extension code like this:
    <Render>
        <Extension Name="EXCEL" Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering">
            <Configuration>
                <DeviceInfo>
                    <SimplePageHeaders>TRUE</SimplePageHeaders>
                </DeviceInfo>
            </Configuration>
        </Extension>
    </Render>
    4. Save the RSReportserver.config file.
    Note: Changing the rendering extension parameters only affects rendering operations on the Report Server.

    When I access to Report Manager and export the report(includes a page header) to Excel format, the result as shown in the following figure:
     SimplePageHeader

    Regards,
    Bin Long


    Monday, July 18, 2011 7:30 AM
    Moderator

All replies

  • Hi Malahaxmi,

    In Reporting Services, the “SimplePageHeaders” setting indicates whether the page header of the report is rendered to the Excel page header. The default value is “FALSE” and it indicates that the page header is rendered to the first row of the worksheet.

    In order to display the page header in the Header/Footer section of Excel, we need to set the “SimplePageHeaders” setting value to “TRUE”. I did a test on my local machine here are my steps:
    1. Navigate to RSReportserver.config file: <drive:> Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\RSReportserver.config.
    2. Backup the RSReportserver.config file before modify it, open the RSReportserver.config file with Notepad format.
    3. Set the Excel rendering extension code like this:
    <Render>
        <Extension Name="EXCEL" Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering">
            <Configuration>
                <DeviceInfo>
                    <SimplePageHeaders>TRUE</SimplePageHeaders>
                </DeviceInfo>
            </Configuration>
        </Extension>
    </Render>
    4. Save the RSReportserver.config file.
    Note: Changing the rendering extension parameters only affects rendering operations on the Report Server.

    When I access to Report Manager and export the report(includes a page header) to Excel format, the result as shown in the following figure:
     SimplePageHeader

    Regards,
    Bin Long


    Monday, July 18, 2011 7:30 AM
    Moderator
  • Hi Bin Long,

    It works when I export the report to excel from Report Manager. Thanks A lot. I was exporting the report from SQl Server Business Intelligence Development Studio till now.

    Thank you.

    Tuesday, July 19, 2011 9:55 AM
  • I have copied this code in my config file

    <Extension Name="EXCEL" Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering">
            <Configuration>
                <DeviceInfo>
                    <SimplePageHeaders>FALSE</SimplePageHeaders>
                </DeviceInfo>
            </Configuration>
        </Extension>

    Restarted Reporting Services Server.

    Deployed my reports to report server.

    Opened reports from report server.

    exported my report to excel 

    when i opened the excel sheet I still found the report header displayed (My requirement is that this header should not be visible when I export to excel sheet)

    Please help me where I am missing.

    Thanks,

    Balaji

    Monday, February 5, 2018 10:23 AM
  • I have copied this code in my config file

    <Extension Name="EXCEL" Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering">
            <Configuration>
                <DeviceInfo>
                    <SimplePageHeaders>FALSE</SimplePageHeaders>
                </DeviceInfo>
            </Configuration>
        </Extension>

    Restarted Reporting Services Server.

    Deployed my reports to report server.

    Opened reports from report server.

    exported my report to excel 

    when i opened the excel sheet I still found the report header displayed (My requirement is that this header should not be visible when I export to excel sheet)

    Please help me where I am missing.

    Thanks,

    Balaji

    Did you read the post at all?

    It is not related to what you're asking

    Its not discussing on how to hide the header for EXcel rendering but whther it should be displayed as Excel header or as first row data


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Monday, February 5, 2018 10:29 AM