An OLE DB error has occurred. Error code: 0x80040154


  • Hello,

    I am getting this error when trying to run a package from a job step.  The package connects to an Oracle database and copies data from a materialized view into a SQL Server database.

    Executed as user: xxxxx ...ility  Version 9.00.4035.00 for 32-bit  Copyright (C) Microsoft Corp 1984-2005. All rights reserved.    Started:  2:53:08 PM  Error: 2009-03-10 14:53:09.85     Code: 0xC0202009     Source: myPckg Connection manager "SourceConnectionOLEDB"     Description: SSIS Error Code DTS_E_OLEDBERROR.  An OLE DB error has occurred. Error code: 0x80040154.  An OLE DB record is available.  Source: "Microsoft OLE DB Service Components"  Hresult: 0x80040154  Description: "Class not registered".  End Error  Error: 2009-03-10 14:53:09.85     Code: 0xC020801C     Source: Data Flow Task Source - OracleView [1]     Description: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER.  The AcquireConnection method call to the connection manager "SourceConnectionOLEDB" failed with error code 0xC0202009.  There may be error messages posted before this with more information on why the AcquireConnection method call failed.  End Error  Error: 2.  The step failed.

    I've read the threads already posted.  This is running 32-bit. 

    I've tried:

    Setting up on my own machine.  It works.
    Manually importing from Oracle using Import Data ... Wizard.  This works;  I saved the package from the manual process.  Ran under my userid.
    Running package from an Integrated Services connection.  Ran under my userid.  It worked;
    Running package from a job step under agent service account.  This fails.
    Setting up a proxy that points to my user id and running job step package under proxy.  This fails but did print my userid as the running user.
    Creating the job as a cmdExec instead of SQL Server Integrated Systems.  Did not work.

    The interesting thing is that the table is created correctly on the SQL Server side so I know the Oracle connection is working.  But it fails before loading the data.  I've tried giving the running users owner on the SQL Server database.

    Tuesday, March 10, 2009 7:41 PM


  •  use dtexec and the cmdexec subsystem in the job.  turn on ssis logging if you haven't already done so.  then, post the messages.
    Duane Douglas, MCAD | | Please mark the post(s) that answered your question.
    • Marked as answer by Tony Tang_YJ Friday, March 20, 2009 9:56 AM
    Wednesday, March 11, 2009 6:39 AM