locked
Unable to log in to SSEE RRS feed

  • Question

  • I'm about to add an website from another server.
    The problem is that I'm no longer able to log on to the SSEE database. I loged on to it by using SQL 2005 Management Studio Express.
    One time I probably chose wrong and loged on with SQL Server 2008 Managemnt Studio. I received a messagebox and probably answared wrong. I don't remember the question. 
    I have tryed several solutions.
    The errormessage I'm receiving now is 18452 Cannot connect to  \\.\pipe\MSSQL$Microsoft##ssee\sql\query
    Login failed for user xxxx
    I have tryed both with SA authentication and Windows Authentication and receive the same error with both.
    It can be that I have confirmed that it shal not be possible to connect to the db with local mashine.

    Is it possible to reset this in some way?

    Thanks for any help with this problem.
    Kristian
    \kf\
    Sunday, March 7, 2010 10:08 PM

Answers

  • i had the same problem on SBS208 premium. The problem was i had to run Management Studio as administrator
    Tuesday, March 16, 2010 10:49 AM

All replies

  • Sorry, the SQL Error was 18456 and NOT 18452.
    \kf\
    Sunday, March 7, 2010 10:14 PM
  • The state of this 18456 error is important. However, you always receive this "Logon Error: 18456" error message that has a state set to 1 in the client application.

    To increase security, the error message that is returned to the client deliberately hides the nature of the authentication error by always setting the state of the 18456 error to 1.

    By default, auditing of failed logins is enabled. In this case, the true state of the 18456 error is reported in the SQL Server Error Log file

     

    So see the error log file for the STATE of this error 18456 from the default path

    C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG

     And the entry for this login failed error in the error log would be something like this

     

    2009-10-08 11:14:18.440    Logon    Error: 18456, Severity: 14, State: 8.
    2009-10-08 11:14:18.440    Logon    Login failed for user 'leks'. [CLIENT: ]

     

    I have documented all the states with its cause and resolution in this article in my website

     

    http://sql-articles.com/articles/troubleshooting/troubleshooting-login-failed-error-18456


    Thanks, Leks
    • Proposed as answer by amjuk Thursday, June 13, 2013 3:56 PM
    Monday, March 8, 2010 1:40 AM
    Answerer
  • I had the same problem signing on to a default install of sharepoint wss.30 uses Sql express 5.0
    Installed the express Sql Management studio locally and used Windows authentication. No go.
    Resoved this problem by the instance name \\.\pipe\MSSQL$Microsoft##ssee\sql\query as the username with windows auth.

    Zart

    Tuesday, March 9, 2010 1:25 AM
  • Sorry KristiF
    Should be "Server Name" as the place to put \\.\pipe\MSSQL$Microsoft##ssee\sql\query.
    Look in the errorlog file for the instance of SQl you are running if you changed the name of the default instance. Look for \\.\pipe string in the errolog file for your qualifier
    Tuesday, March 9, 2010 1:32 AM
  • i had the same problem on SBS208 premium. The problem was i had to run Management Studio as administrator
    Tuesday, March 16, 2010 10:49 AM
  • Thank you rimroot.

    Didn't think of this. It worked without runing as Administrator at first, but suddenly I was unable to log in.

    Your tip got me running again. I'm back in. :)

    \kf\

    Thanks to Lekss as well. Great article.

     


    \kf\
    Tuesday, March 23, 2010 11:13 PM
  • Thanks for a great fill in for all the MS forgot.

     

    really helpful and grateful


    D-B-S
    Thursday, May 27, 2010 9:35 PM
  • if you get a “Login failed” message when you try to connect?

    SQL SSEE 1

    Run as Administrator

    You probably forgot to run SQL Server Management Studio Express as Administrator.

    SQL SSEE 2

    Regards

    Bhupen

    Monday, December 26, 2011 11:09 AM
  • A "thanks" isn't enough, but thanks!
    Tuesday, April 10, 2012 3:15 PM
  • To make something permanently run as an administrator, right click on the program's shortcut, click on "Compatibility", then click on the "Run this program as administrator" checkbox at the bottom of the dialog box.  You won't have to remember to do this anymore; it will ask you automatically.
    Tuesday, April 10, 2012 3:23 PM
  • I had the same Problem, that the instance wasn´t available and i couldn´t connect to it.  In my case the "Named Pipes" Option was not activated and the wrong path stand in the sql management studio. 

    Edit - SQL Serverprotocol

    ###############################

    SQL Server Configuration Manager
    SQL Server Network configuration

    protocol for "Microsoft##SSEE"

    Named Pipe "Activated"

    instance Path

    ###############################

    \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query

    Monday, April 25, 2016 9:05 AM