SharePoint Designer Error - The server could not complete your request


  • Server Information

    SharePoint 2010 Foundations
    One Web Application that is extended with for external access with SSL cert.
    Windows Authentication

    Last week I had no issues getting into SharePoint Designer and I am not sure what has changed.  When I try to open a site with SharePoint Designer I get prompted for username and password and after entering that inforamtion it looks like it is going to connect and then I get a dialog box that reads "The server could not complete your requst. For more specific information, click the Details button". The Detailed information is blank. After clicking okay I get  a second Dialog that reads "An error occurred while trying to fetch data from your SharePoint site. Unexpected response from the server. The content typ of th responce is"". The status code is "Ok"."

    Here is the event log from the server

    WebHost failed to process a request.

    Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/48626873

    Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/client.svc' cannot be activated due to an exception during compilation.  The exception message is: Method not found: 'System.String System.ServiceModel.Activation.Iis7Helper.ExtendedProtectionDotlessSpnNotEnabledThrowHelper(System.Object)'.. ---> System.MissingMethodException: Method not found: 'System.String System.ServiceModel.Activation.Iis7Helper.ExtendedProtectionDotlessSpnNotEnabledThrowHelper(System.Object)'.

       at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.WebConfigurationManagerWrapper.BuildExtendedProtectionPolicy(ExtendedProtectionTokenChecking tokenChecking, ExtendedProtectionFlags flags, List`1 spnList)

       at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.WebConfigurationManagerWrapper.GetExtendedProtectionPolicy(ConfigurationElement element)

       at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.ProcessWindowsAuthentication(String siteName, String virtualPath, HostedServiceTransportSettings& transportSettings)

       at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.CreateTransportSettings(String relativeVirtualPath)

       at System.ServiceModel.Activation.MetabaseSettingsIis.GetTransportSettings(String virtualPath)

       at System.ServiceModel.Activation.MetabaseSettingsIis.GetAuthenticationSchemes(String virtualPath)

       at System.ServiceModel.Web.WebServiceHost.GetAuthenticationSchemes(Uri baseAddress)

       at System.ServiceModel.Web.WebServiceHost.AddAutomaticWebHttpBindingEndpoints(ServiceHost host, IDictionary`2 implementedContracts, String multipleContractsErrorMessage)

       at System.ServiceModel.Web.WebServiceHost.OnOpening()

       at Microsoft.SharePoint.Client.Services.MultipleBaseAddressWebServiceHost.OnOpening()

       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

       --- End of inner exception stack trace ---

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

    Process Name: w3wp

    Process ID: 2960

    Have I search and found other posts but non of them help.  Please point me in the correct direction if possible.

    Thank you,

    Monday, January 14, 2013 10:19 PM


All replies

  • Hi Phillip6653,

    Did you check the similar thread to uninstall the windows update KB2756920 which was published on day 1/10? After auto install the update, on day 1/11, the same error occur when I open site using designer, after I uninstall it, it works for me, please have a check.

    For more information, see

    Best Regards.

    Kelly Chen
    TechNet Community Support

    • Marked as answer by Phillip6653 Tuesday, January 15, 2013 2:29 PM
    Tuesday, January 15, 2013 9:42 AM
  • Thank you this worked like a charm. With I would have found the post yesterday before spending hours trying to fix. :)
    Tuesday, January 15, 2013 2:29 PM
  • This is because WCF only supports one binding per IIS web site. Also, this is not the only place that you will see issues like this. Try to invoke something from SP client object model, or call Designer, etc...

    The solution is to clean up your web applications via IIS and Central Admin. Make sure you don't have host header names on the same IP: Port. for instance you may have two web app on port 80. get rid of one or do a work around like pointing to a new ip address if you can add a new ip to your server....


    Friday, April 11, 2014 12:09 AM