locked
Cannot install Azure Active Directory Module for Windows PowerShell. MOSSIA is not installed RRS feed

  • Question

  • On my Windows Server 2008 R2, when trying to install Windows Azure Active Directory Module for Windows PowerShell i got the following error message (although Microsoft Online Services Sign-In assistant version 7.0 is installed) 

    "In order to install Windows Azure Active Directory Module for Windows PowerShell, you must have Microsoft Online Services Sign-In Assistant version 7.0 or greater installed on this computer"

     NB : on  a french server  "Pour installer le Module Windows Azure Directory pour windows PowerShell, l'Assistant de connexion de Microsoft Online Service 7.0 ou version ultérieure doit être installé sur cet ordinateur".

    Tried to uninstall/ /repair / ... Microsoft Online Service Sign-In assistant, but not helped....


    Etienne Bailly | SharePoint Consultant | My Blog

    samedi 15 juin 2013 15:56

Réponses

Toutes les réponses

  • Maybe thats your solution:

    http://community.office365.com/en-us/forums/148/p/169890/497288.aspx#497288

    Somemismatch on dependency check, the Beta-version of the sign-in assistant fixed the problem for me and the guys on the thread.

    mercredi 19 juin 2013 10:55
  • 

    Dear Freinds, i am also struggling with this problem i have installed the latest suggested BETA from the link but face the same issue.

    I tried this on This is really frustrating as this has become a challenge for me infront of management.

    Please advise possible solutions, how to get module loaded manually in PS or some other better thing.

    jeudi 20 juin 2013 18:44
  • Same issue here on Windows 8.  What's up Microsoft???

    jeudi 27 juin 2013 18:20
  • The workaround solution is to install instead the Microsoft Online Services Sign-In Assistant for IT Professionals BETA

    http://www.microsoft.com/en-us/download/details.aspx?id=39267

    Etienne.


    Etienne Bailly | SharePoint Consultant | My Blog

    mardi 9 juillet 2013 09:26
  • Hello all,

    I too experienced same error but JFYI yesterday I've found that applying workaround described below before installing AADM for WinPS (Azure Active Directory Module for Windows PowerShell) indeed worked perfectly.

    Because others might too dislike to use MOS SIA Beta (Microsoft Online Services Sign-In Assistant build 7.250.4551.0) in their production environments, I'm sharing my solution here to provide such alternative while having MOS SIA RTW (Microsoft Online Services Sign-In Assistant v2.1 but build 7.250.4303.0 when installed).

    A) To temporarily change MOS SIA RTW version copy at least 6 lines below inside Notepad and save file as TempVerMOSSIA.reg, then double click it to merge changes into registry, then install AdministrationConfig-xx.msi (which means AdministrationConfig-fr.msi for Etienne, or AdministrationConfig-en.msi for english readers, for me it was  AdministrationConfig-it.msi)

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSOIdentityCRL]
    "MSOIDCRLVersion"="7.250.4551.0"
    "MSOIDCRLVersion_Default"="7.250.4303.0"

    B) To restore original MOS SIA RTW version just copy at least 6 lines below inside Notepad and save file as RevertVerMOSSIA.reg then double click it.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSOIdentityCRL]
    "MSOIDCRLVersion"="7.250.4303.0"
    "MSOIDCRLVersion_Default"="7.250.4303.0"

    I hope this can help, like it did for me.

    Regards

    Rob


    • Proposé comme réponse _RobMer_ mercredi 7 août 2013 01:29
    • Modifié _RobMer_ mercredi 7 août 2013 01:30 corrected a typo
    mercredi 7 août 2013 01:29
  • Thanks a lot, it worked for me perfectly.

    J

    vendredi 23 août 2013 15:31
  • The beta fixed MSOL Powershell, but broke Lync my ability to sign in to Lync.
    mardi 17 septembre 2013 15:21
  • Works like a charm!

    No existen imposibles sino incapaces

    vendredi 27 septembre 2013 15:36
  • Registry fix worked for me. Thanks for posting it.

    Phil

    lundi 18 novembre 2013 13:54
  • So here we are 6 months later.... now I'm on Server 2012R2... are we still having to hack the register or run beta in our production? I'm having the same stupid issue....still

    -SuperDale

    mardi 26 novembre 2013 05:43
  • The "MSOIDCRLVersion"="7.250.4551.0" hack does work but please? What is this? Microsoft?
    mercredi 27 novembre 2013 17:14
  • Registry fix worked for me. Thanks
    lundi 27 janvier 2014 15:45
  • Running Windows2012R2 and not able to make reg. hack work either.  Followed steps above...  Any suggestions?
    mercredi 12 février 2014 15:50
  • mercredi 12 février 2014 18:14
  • I was through the same pain with Win8 Pro and installed the BETA version of MSOL Sign-in assistant helped.

    On Win7 I don't have this issue and worked with RTW version fine.

    jeudi 20 février 2014 04:22
  • This is such baloney.  I went through the whole reg hack with the beta version and that resolved the first error message.  Then it said I needed .NET Framework 3.51 SP1 or greater.  When I attempted to install .NET 4 it said I already had that or a higher version on my Win 8.1 PC. Control Panel said it was .NET 1.1 so I uninstalled that rebooted and tried 4 again.  Same message. Then I tried 3.5. That did it.

    Come on Microsoft!  We need these tools to run PowerShell with Office 365.  Why make it so hard?

    jeudi 6 mars 2014 22:33
  • The beta online services sign-in assistant worked for me also.  Server 2008R2.
    lundi 7 avril 2014 16:07
  • it has always been hard, or fraught with issues. I had to fight with my anal admin, whose (correct) policy it is to refuse to install something that says "beta". Almost sabotaged the whole adopt

    What is interesting is the role of the service, it installs.

    Its essentially a credential store, talking to the STS at the outset so apps, like lync or outlook, might NOT need to wait around on the STS. Similarly, powershell app. This has to "evolve" now, with the whole token store concept for native apps, based on JWTs, and offline access when tokens control DRM-ed content.

    I sometimes feel like its old US antitrust issues that PREVENT microsoft from doing things right, here.

    lundi 7 avril 2014 19:21
  • Installing the Beta will keep some other applications that use the Sign-in assistant from working.

    We've experienced this with Dynamics CRM Outlook Integration: This component only works with the last RTM release of the Sign-in assistant, not with the newer Beta that is required for AAD PS.


    vendredi 2 mai 2014 15:57
  • .Net 3.51 and .Net 4 are completely different products. Admittedly confusing naming! But they have different APIs so both may need to be installed for different products to work.
    vendredi 30 mai 2014 20:37
  • Thank you kindly.

    Works perfect even without a reboot.

    http://blogs.technet.com/b/tune_in_to_windows_intune/archive/2013/11/09/error-when-trying-to-install-windows-azure-active-directory-module-for-windows-powershell.aspx


    mardi 2 septembre 2014 21:56
  • Hello all,

    I'm updating again this thread just because I believe that a definitive solution (no more Beta :-D ) indeed already exist for sure for Etienne Bailly (who asked this Q) and for others with Windows 8.1 / 8 clients because of latest 'Microsoft Online Services Sign-In Assistant for IT Professionals RTW' corresponding to version 7.250.4556.0 was already released to web (RTW) a while back (on 2/17/2014).

    P.S. About others with more updated servers (Windows Server 2012 R2 isn't really listed among supported OSes excerpt I'm adding here too) I expect them to get a solution too because of modern client (Windows 8.x) support (while JFYI its install failed when I tried on a Windows XP Professional SP3 I have around).

    "Supported operating systems: Windows 7, Windows 8, Windows 8.1, Windows Server 2008, Windows Server 2008 R2, Windows Vista"

    "Supported processor architectures: x86 and x64 for all supported operating systems"

    Regards

    Rob

    • Proposé comme réponse _RobMer_ vendredi 10 octobre 2014 17:22
    • Modifié _RobMer_ vendredi 10 octobre 2014 17:25 Just better evidencing current RTW version...
    vendredi 10 octobre 2014 17:21
  • _RobMer_ solution worked for me.
    mardi 11 novembre 2014 02:17
  • the registry fix method worked for me. seems like a more clean hack rather than putting the beta app and causing other issues.
    lundi 29 décembre 2014 09:40
  • Hi Etienne.

    This does not work for some users. I have that installed and I still get the error.

    vendredi 9 janvier 2015 13:25
  • Hi ReliableRick,

    I just uninstalled/re-installed MOSSIA and Azure AD PS module and did not hit any error. In my case it installed MOSSIA v 7.250.4556.0. Can you clarify/confirm what error you are seeing? Is it exactly the same as Etienne's original post? I know the engineering team recently spent time working out various problems with this installation, so very interested to see what might be wrong here.

    Thanks,

    Justin

    vendredi 9 janvier 2015 20:22
  • You Rob, are a superhero, and making up for the MISERY that Azure and its problems cause us on a daily basis
    mercredi 1 avril 2015 15:08
  • Just install latest version 'Microsoft Online Services Sign-In Assistant for IT Professionals RTW' corresponding to version 7.250.4556.0 and that fixed my issue.
    dimanche 15 novembre 2015 20:08