none
WAP not firing SMA running books on events

    Question

  • Hi All,

    I have deployed WAP with System Center 2012 r2(Orch, VMM, SPF, SMA) to manage a group of test servers. I need to be able to fire SMA runbooks when i user account is first created and another when VM's are created or deleted.

    I have created a test hello world powershell runbook to just write output. This run book runs when i test it or start it manually, it also runs when i schedule it. 

    My runbook does not start when i add a user or create a VM. I have linked the runbook the following

    Runbook name: test-HelloWorld

    Tag: SPF

    Linked to: SPF Tenant, Create Event

    Linked to : VMM VirtualMachine, Create Event.

    All servers use a wildcard 3rd party trusted SSL (*.domain.com)

    Any ideas?

    Wednesday, July 2, 2014 12:45 AM

All replies

  • I'm unfortunately experiencing the same problem with SPF Tenant Create Event. 

    Do you also get incorrect information if you edit your SPF Tenant Create entry, as seen here?
    Notice how it says "VMM VirtualMachine" even though I did edit the SPF Tenant entry.

    Wednesday, July 2, 2014 9:13 PM
  • I've seen the exact issue, you need to make sure that SPF app pool account is a member of a local smaadmingroup on the SMA server.

    Oh and I've seen the issue just like on the screen shot. I think I fixed it by deleting all the event triggers and registering SPF Tenant - Create first, and the others after


    The data above this text is pseudorandom, brace yourselves.




    Thursday, July 3, 2014 6:58 AM
  • Hi,

    thanks for this hint, BUT is was not working.

    I had alredy the Domain\scvspf-User part of the smaAdminGroup on the SMA Server ;(

    Any ideas??

    thy in advance, Stefan    - manage.acpcloud.rocks


    Azure Pack rocks -> ACP Cloud Services Austria - www.acpcloud.rocks

    Tuesday, December 23, 2014 8:35 PM
  • You should start a new thread. And try doing steps I've outlined above.

    Oh and I've seen the issue just like on the screen shot. I think I fixed it by deleting all the event triggers and registering SPF Tenant - Create first, and the others afterOh and I've seen the issue just like on the screen shot. I think I fixed it by deleting all the event triggers and registering SPF Tenant - Create first, and the others after


    The data above this text is pseudorandom, brace yourselves.



    Wednesday, December 24, 2014 6:22 PM
  • Hi, it was not helpiong, sorry:

    i delete and reregister all my (test-)Events with this script, but it is still not working. The ONLY Events are fired are the "Subscription"  Create, Update, Delete 

    Any ideas?

    $rb = Get-SCSPFEventRegistration 
    $rb.Count
    
    $rb | ForEach-Object { 
        Set-SCSPFEventRegistration -Resource $_.Resource -Action $_.Action -RunbookName "" 
    }
    
    Set-SCSPFEventRegistration -Resource SPF.Tenant -Action Create -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource SPF.Tenant -Action Update -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource SPF.Tenant -Action Delete -RunbookName Send-SPFInfo2Mail -Enabled 
    
    Set-SCSPFEventRegistration -Resource Subscription -Action Create -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource Subscription -Action Update -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource Subscription -Action UpdateStatus -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource Subscription -Action Delete -RunbookName Send-SPFInfo2Mail -Enabled 
    
    Set-SCSPFEventRegistration -Resource VMM.VirtualMachine -Action Create -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource VMM.VirtualMachine -Action Update -RunbookName Send-SPFInfo2Mail -Enabled 
    Set-SCSPFEventRegistration -Resource VMM.VirtualMachine -Action Delete -RunbookName Send-SPFInfo2Mail -Enabled 


    Azure Pack rocks -> ACP Cloud Services Austria - www.acpcloud.rocks


    Tuesday, December 30, 2014 10:56 AM