none
Error when running workflow form list item - workflow manager SharePoint 2013

    Question

  • I am getting the following error in the workflow services log when I tried to run a SPD 2013 workflow from as list item. The workflow page comes up with an "An unexpected error has occurred" page when opened:

    Error processing management request. Method: GET, RequestUri: http://servername:12291/$Workflows/$Instances?$skip=0&$top=100&monitoringParameter=1f51aa43-2f1c-4fc5-a86d-f638ca57c00d, Error: System.Data.SqlClient.SqlException (0x80131904): The procedure "GetInstances" has no parameter named "@OtherWorkflowStatus".
       at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at Microsoft.Workflow.Gateway.HttpAsyncResult.End[TAsyncResult](IAsyncResult result)
       at Microsoft.Workflow.Gateway.WorkflowServiceGateway.<>c__DisplayClass9d.<EndGetInstances>b__9c()
       at Microsoft.Workflow.Gateway.WorkflowServiceGateway.ExceptionFilter[T](Func`1 body)
       at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
    ClientConnectionId:d2039360-b352-4d81-9bb7-b647e2938d06

    Can't find anything on google.

    Edit: Ok, when I look at the error, it is saying the the "GetInstances" stored procedure in the WFInstanceManagementDB database does not have a parameter named "@OtherWorkflowStatus". For laughs, I added the parameter (which wasn't in there). Now I get the error:

    Procedure or function 'GetInstances' expects parameter '@OtherWorkflowStatus', which was not supplied

    It seems like there is something not right about my installation. Previously, I couldn't get the workflow backend service to run because there were config values missing from the workflow manager database. At the time I tried to uninstall/reinstall WFM to no avail. I eventually had to manually add the values to get it to work. Something is not right about the WFM install/config process.





    Sunday, January 26, 2014 6:51 PM

All replies

  • I am running into same problem. Can you please tell me what change did you make manually to make it work? -Thanks
    Monday, February 03, 2014 5:29 AM
  • Here is what I had to do to get it working:

      • Leave the WFM (Workflow Manager) farm using the WFM config tool
      • Uninstall WFM, Service Bus, and the CU's from control panel
      • Uninstall Workflow Manager Client if it exists in the control panel, it didn't in mine
      • Delete the following databases in SQL Server:
        • SbGatewayDatabase
        • SbManagementDB
        • SBMessageContainer01
        • WFInstanceManagementDB
        • WFManagementDB
        • WFResourceManagementDB
      • Delete the workflow proxy service in Central Admin (important)
        • Application Management > Manage Service Applications
        • Highlight (select) the Workflow Service Application Proxy service (don’t click the hyperlink)
        • Select “Delete” from the ribbon.
      • Restart the server
      • Reinstall
      • Enable the workflow proxy service in CA for the web app, the 2013 workflow option will not show up in SPD unless you do this.
      • Application Management > Manage Web Applications
      • Select your web app
      • Select “Service Connections” from the ribbon
      • Check the Workflow Service Application Proxy item and click “OK”



    Monday, February 03, 2014 3:13 PM
  • Thanks, that was very helpful. I uninstalled everything as you said and followed this video tutorial which was hepful: http://msdn.microsoft.com/en-US/library/dn201724
    Tuesday, February 04, 2014 2:14 AM