locked
Cannot use Internationalized domain name for Azure Web Site RRS feed

  • Question

  • I need to use internationalized domain name with azure web site. But I cannot register it, the error "Invalid format". I cannot use punycode also. The portal UI does not allow "-" symbol for 1 level domain name part.

    Is it possible to use internationalized domain name with azure? And if so, how to enter the name properly?


    • Edited by VlH Wednesday, October 16, 2013 8:24 PM
    Wednesday, October 16, 2013 8:24 PM

Answers

All replies

  • Hi VIH,

    Base on me experience, currently Azure doesn't  seem like support special characters in domain names, for example your IDN included the "-". You could refer to this same thread (http://social.msdn.microsoft.com/Forums/windowsazure/en-US/5b98a822-e2fb-47e1-8a4b-00af3814c322/bug-idn-domains-and-punycode ). Also, I suggest you contact azure support team via http://www.windowsazure.com/en-us/support/contact/

    If I misunderstanding, please let me know.

    Thanks

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by VlH Saturday, October 19, 2013 8:43 AM
    Thursday, October 17, 2013 3:32 AM
  • I want "specific domain" with internationalized domain name (IDN), this is a bit different, as it turned out.
    Thursday, October 17, 2013 5:05 AM
  • Will, so, u suppose, it does not support IDN's. That's ruefully. I'll try support for the last resort, thanks.
    Thursday, October 17, 2013 5:09 AM
  • it is supported now.
    Friday, August 8, 2014 5:54 PM
  • Could you please explain how ?

    I managed to register the custom IDN's in punyencoded format but all request to the domain results in the default 404 Azure page (indicating that all the DNS records are valid)...

    SOLVED 2014-08-21:

    Using the new portal I was able to type in the actual local characters (instead of the punyencoded) and then (even if there was no new entries added) it started to work !

    /b



    • Edited by bang75 Thursday, August 21, 2014 8:56 AM SOLVED
    Tuesday, August 19, 2014 4:01 PM
  • Hi,

    I am trying this with a domain containing German Umlauts, and it does not work. The Umlaut domain name is not accepted by the Azure's "manage domains" form. And although the punycode format is accepted by the form, it does not work. Still only getting 404 errors.

    Some forums say that Azure takes up to 72 hours to populate it's DNS records, but even after that time I only get 404 errors.

    Did anyone succeed with Umlaut domains? Is this supposed to work?

    Thanks,

    S. Vogel

    Monday, October 20, 2014 7:35 PM