none
檢視網頁後發現"Internet Explorer 無法顯示網頁" RRS feed

  • 一般討論

  • 作業系統:Win XP sp3

    IE版本:8


    我去控制台看了一下IIS
    找不到版本資訊

    NET Framework 版本
    我去了新增移除程式看了一下我有 2.0 3.0 3.5的版本

    Visual Studio的版本是2008

    防毒軟體:無

    我找過一篇文章跟我類似~但是他的作業系統是Vista, IE是7跟我不一樣

    各位大大好
    我有個問題想請教
    我安裝好MVS2008後
    點選"新增專案"->然後點選"ASP.NET Web 應用程式"
    隨便放了幾個按鈕跟text後
    點選"在瀏覽器中檢視後"
    沒有反應
    瀏覽器沒跳出來
    後來在螢幕右下方點的"ASP.net程式開發伺服器"上按右鑑然後點選"在Web 瀏覽器中開啟"
    結果IE居然顯示"Internet Explorer 無法顯示網頁"
    右下角的port跟網址的都一樣
    由於MVS2008沒反應
    所以只好點螢幕右下方點按右鑑然後點選"ASP.net程式開發伺服器"上按右鑑然後點選"停止"
    接著就出現"無法連接到ASP.net程式開發伺服器"

    後來我去如意ASP.net網站去看安裝教學
    教學說我必須要先安裝IIS
    而且說要先移除先前安裝的MVS2008
    我移除了MVS2008
    另一個網站還告訴我要移除 MS Net Framework 1.X 的版本
    我也移除了
    然後安裝IIS
    最後重新開機安裝MVS2008
    可是問題仍然存在
    後來我google到一個網頁
    叫我到'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727' 執行 aspnet_regiis -i
    然後再執行iisreset
    但是都沒有用
    請問各位大大我該怎麼辦?
    拜託幫個忙

    • 已變更類型 91MVP, Moderator 2010年9月22日 下午 03:26 問題已經獲得解決,確切原因不確定。
    2010年8月26日 下午 03:44

所有回覆

  • 您有沒有安裝防毒軟體啊!有時候有些防毒軟體防的過頭,會影響到開發工具的。

    由於您使用 Web Development Sever (即ASP.net程式開發伺服器),或 IIS 上的 asp.net 程式都失敗,我才做其他的猜測。

    2010年8月26日 下午 11:39
  • 你用的是應用程式,但從頭到尾沒看到你做編譯的動作,「在Web瀏覽器中開啟」是不會幫你編譯的

    改用Ctrl + F5

    2010年8月27日 上午 01:17
    版主
  • 如果您想要建立網站的話,建議用:

    檔案-->新網站-->範本(選擇ASP.NET網站)-->位置(可以指定到您想到的目錄下)-->語言(選擇自己會的)-->確定

    這樣才是標準網站的模式,一般用新增專案的方式,是要建構較複雜的系統來使用的,

    若要執行請按F5或工具列上有一個綠色三角形的按鈕,

    這樣先試試看。

    2010年8月27日 上午 01:41
  • 謝謝大大

    我沒有安裝任何防毒軟體

    會不會有其他可能性?

    2010年8月27日 下午 01:54
  • 您好 ,

    您先確定一下 IIS 是不是可以正常的 On 起來,

    可以的話再安裝 Visual Studio~

     

    小弟自己的安裝步驟是:

    1. 安裝 IIS 5.x

    2. 安裝 .NET Framework 3.5

    3. 安裝 SQL Server 2005 Express

    4. 安裝 Visual Studio 2008

    一步一步做,看看哪一步有問題,這樣比較不會抓不著頭緒~~~



    Best regards

    • 已編輯 DK. Da 2012年6月10日 上午 01:44
    2010年8月27日 下午 01:55
  • 我放了幾個Text跟Label 還有按鈕

    Ctrl+F5按了會沒反應

    沒有任何瀏覽器跳出來

     

    2010年8月27日 下午 01:57
  • 我用您的方式

    新網站

    我放了幾個text跟label後然後用您的方式執行

    最後出現直接跳出"無法連接到ASP.NET程式開發伺服器"

    仍然沒用呢=.=

    拜託大大幫我想想看會不會有其他問題

    2010年8月27日 下午 02:04
  • 謝謝Albert大大

    要如何確定IIS是不是on?

    我想請問我應該要先移除VS2008跟NET Framework 3.5還有IIS吧?

    我的新增移除程式裡面有NET Framework 2.0   3.0  3.5   這些都要先移除掉嗎?

    另外NET Framework 3.5跟SQL Server 2005 Express 在安裝VS2008時就好像一起安裝了...

    可是我已經試過先安裝IIS在安裝VS2008

    結果都一樣

    2010年8月27日 下午 02:17
  • 我等不及你回應了

    我自己先做

    我移除VS2008, iis net framwork 3.5

    我先安裝iis

    在去MS網站下載NET Framework 3.5

    然後安裝

    接著安裝SQL時

    VS2008要求我要裝SQL就要連VS2008一起裝

    不得已只好一起裝

    結果最後還是一樣不能執行

    我真的有點累  /___\

    居然卡在這邊..

    2010年8月28日 上午 01:40
  • 這跟IIS沒有關係,

    先檢查下面的設定:

    1.在方案總管的網站按右鍵==>屬性頁==>起始選項==>伺服器==>使用預設Web伺服器,

      偵錯工具是否有勾選Asp.Net

    2.另外在建置頁==>執行啟動頁面之前==選擇建置網站,

      目標Framework==>.NET Framework 3.5


    2010年8月28日 上午 04:55
  • 謝謝天叢雲大大

    我照著您的第一步驟去做

    偵錯工具已經有勾選Asp.net了

    另外第二項也早就設定好了

    但是還是無法執行=.=

    2010年8月28日 下午 06:23
  • 案總管的網站按右鍵==>瀏覽方式==>瀏覽器==>這裡是選擇什麼??

    另外有在

    工具列==>建置==>建置網站

    有執行過嗎?

    2010年8月29日 上午 05:47
  • 我在按下右鍵==>然後選擇瀏覽方式後整個vs2008會沒反應,最後會跳出"無法連接到ASP.net程式開發伺服器"

    我在工具列===>點"建置"===>點"建置網站"後沒有任何瀏覽器跳出來,就只有輸出視窗出現以下訊息.

    ------ 已開始建置: 專案: H:\...\WebSite2\, 組態: Debug .NET ------
    正在驗證網站
    繫結目錄 '/WebSite2/'。

    驗證完成
    ========== 組建: 1 成功或最新狀態、0 失敗、0 略過 ==========

     

     

    2010年8月29日 下午 03:03
  • 會不會是這個問題

    http://www.dotblogs.com.tw/topcat/archive/2008/03/06/1286.aspx

     


    topcat(姍舞之間的極度凝聚)http://www.dotblogs.com.tw/topcat/
    2010年8月30日 上午 05:43
    版主
  • 應該不可能

    因為我沒出現"無法存取 IIS Metabase"訊息

    而且小喵大大若仔細看我的文章

    我已經做過"aspnet_regiis -i"動作了

    2010年8月30日 下午 01:13
  • 謝謝天叢雲大大

    也感謝各位大大

    雖然不知道怎麼搞得

    我也沒做任何動作忽然可以用了

    也謝謝天叢雲大大鍥而不舍的幫忙

    我會給各位大大的每個文章投票

    2010年8月30日 下午 10:03
  • 恭喜啊~~~!

    不過最好還是把原因找出來,

    不然以後再遇到這種狀況還是會很傷腦筋啊~~~



    Best regards

    • 已編輯 DK. Da 2012年6月10日 上午 01:44
    2010年8月31日 上午 03:39