none
Single-line comment or end-of-line expected RRS feed

  • 問題

  • #define DEFAULT_HEX_WIDTH=2//nothing
    I add the line at the first lin of cs file. But is appears the error message as below:
    Single-line comment or end-of-line expected

    How do I resolve this problem?
    • 已編輯 akira32 2009年7月21日 下午 04:03 add
    2009年7月21日 下午 04:03

解答

  • #define preprocessor is not supported in C#, please use "const" to declare your constants.


    小人物一枚。
    • 已標示為解答 Lolota Lee 2009年7月28日 上午 06:11
    2009年7月21日 下午 04:09
    版主
  • You can only use #define to set compiler flag on or off, but not set it to a sepecific value. Here is the reference from MSDN.
    • 已標示為解答 Lolota Lee 2009年7月28日 上午 06:11
    2009年7月21日 下午 08:48
  • HI,

    C/C++語言的define要這樣寫:
    #define DEFAULT_HEX_WIDTH  2

    C#的define要這樣寫:
    #define DEFAULT_HEX_WIDTH

    如果要給值, 可以考慮用const或enum來取代
    • 已標示為解答 Lolota Lee 2009年7月28日 上午 06:11
    2009年7月22日 上午 02:48

所有回覆

  • #define preprocessor is not supported in C#, please use "const" to declare your constants.


    小人物一枚。
    • 已標示為解答 Lolota Lee 2009年7月28日 上午 06:11
    2009年7月21日 下午 04:09
    版主
  • You can only use #define to set compiler flag on or off, but not set it to a sepecific value. Here is the reference from MSDN.
    • 已標示為解答 Lolota Lee 2009年7月28日 上午 06:11
    2009年7月21日 下午 08:48
  • HI,

    C/C++語言的define要這樣寫:
    #define DEFAULT_HEX_WIDTH  2

    C#的define要這樣寫:
    #define DEFAULT_HEX_WIDTH

    如果要給值, 可以考慮用const或enum來取代
    • 已標示為解答 Lolota Lee 2009年7月28日 上午 06:11
    2009年7月22日 上午 02:48