none
關於aspnetdb連結到sql server 2008 standard(webpart) RRS feed

  • 問題

  • 目前修改了LocalSqlService之後 (因為沒安裝sql server 2005 express..)

    <remove name="LocalSqlServer"/>
        <add name="LocalSqlServer" ....>

    aspnetdb的資料表也成功建立在Server的資料庫裡

    能順利連結Server,在網頁上顯示WebPartZone

    但~只有顯示...其他功能都不見了...

    參考了網頁許多大大的意見和方法,但就是不成功

    出錯: WebPartManager1.DisplayMode = WebPartManager.DesignDisplayMode

    在此請教幾個問題~

    環境:

    本機安裝 Sql Server 2008 Management Studio 和 VS 2010

    Server只安裝 Sql Server 2008

    顯示錯誤為

     


    The specified display mode is currently disabled on this page. Make sure personalization is enabled for the current user.
    Parameter name: value

     

    在aspnetdb我並未做任何動作和處理,唯一有的是連結的sa帳號

    而網頁登入是從Server的另一個資料表驗證的

    是不是因為aspnetdb內沒有任何user和role的資料,所以無法使用designmode呢?

    我是不是必須非得在aspnetdb內加入所有的user才行呢? (但asp.net組態能新增user,但不能新增roles,會出現連結錯誤...) 或是有其他方式呢?

    請各位大大幫忙解答~~~

     

    使用網站管理工具時,設定使用者和角色都正常

    但是選擇驗證方式就出錯了:[ 嘗試執行未經授權的作業。]


    • 已編輯 hirosi912 2011年3月28日 上午 08:58
    2011年3月25日 上午 09:00

解答

所有回覆

  • 補充:

    在aspnet.net 組態中,存取規則無法設定,會出現 [ 嘗試執行未經授權的作業。]

    請各位大大幫幫忙了

     

    2011年3月28日 上午 03:02
  • 這個動作:

    WebPartManager1.DisplayMode = WebPartManager.DesignDisplayMode

    必須在使用者登入之後少能夠執行

    2011年3月28日 上午 04:01
  • 嗯 aspnet.net 組態中,使用者和角色都可以設定,就是[存取規則]無法設定

    請問我該如何在config中增加設定呢?

    <roleManager enabled="true">

       <providers>

          <clear/>

          <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="LocalSqlServer" applicationName="/"/>

       </providers>

    </roleManager>


    2011年3月28日 上午 05:02
  • 其實這個錯誤訊息很廣...... T_T 是無言的那種錯誤 , 
    你參考看看之前人的各種解決方案,看能不能排除掉

    http://forums.asp.net/p/1383417/2934674.aspx 

    http://www.dotblogs.com.tw/dotjum/archive/2010/11/30/19820.aspx


    請關心你的發問 ^_^
    2011年3月28日 上午 07:43
  • 還是不行,因為現在是連用網路管理工具都出問題...

    可以設定使用者和角色,就是不能設定驗證模式...

     

    2011年3月29日 上午 01:19
  • 請問您有設定<membership>項目嗎? 例如:SqlMembershipProvider Class
    2011年3月29日 上午 07:15
  • 嗯 有的...

    我發現問題好像是我的檔案放在server端就不能設定存取和驗規則,必須放在本機設定才行...

    2011年3月30日 上午 02:28