none
VS2013 發行問題 RRS feed

  • 一般討論

  • VS2013 update 4

    輸出

    C:\Program Files\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(4769,5): warning MSB3155: 在 'C:\Program Files\Microsoft SDKs\Windows\v8.1A\Bootstrapper\' 中找不到項目 'Microsoft.Windows.Installer.3.1'。
    C:\Program Files\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(4769,5): warning MSB3146: 'Microsoft .NET Framework 4 Client Profile (x86 和 x64)' 需要項目 'Windows Installer 4.5',但卻不包含。
    C:\Program Files\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(4769,5): error MSB3169: 產生啟動載入器時發生錯誤: Unable to begin updating resource for bin\Debug\app.publish\setup.exe with error 800700C1
    錯誤: 無法發行,因為無法建置專案。

    錯誤清單

    警告 3 'Microsoft .NET Framework 4 Client Profile (x86 和 x64)' 需要項目 'Windows Installer 4.5',但卻不包含。 GTtest
    警告 2 在 'C:\Program Files\Microsoft SDKs\Windows\v8.1A\Bootstrapper\' 中找不到項目 'Microsoft.Windows.Installer.3.1'。 GTtest
    錯誤 4 產生啟動載入器時發生錯誤: Unable to begin updating resource for bin\Debug\app.publish\setup.exe with error 800700C1 GTtest
    錯誤 1 無法發行,因為無法建置專案。

    我該怎麼做?

    感謝

    2015年8月25日 上午 08:57

所有回覆

  • [VS2013] Installer 增益集試用

    缺少的項目要從舊版考過來。


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2015年8月25日 下午 01:46
  • 謝謝你的回覆,  但安裝好 Installer, 一樣顯示問題, 沒有解決

    我使用VS2013 也沒收到通知

    2015年8月26日 上午 12:51
  • Hi, tihs

    謝謝你的回覆,依然問題

    我有檢查

    1. 專案屬性--> 必要條件 Windows Installer 4.5 勾選

    2. 電腦-->管理-->Windows Installer -->執行

    3. Cmd --> MSIExec 確認沒問題 

    輸出:

    C:\Program Files\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(4769,5): error MSB3169: 產生啟動載入器時發生錯誤: Unable to begin updating resource for bin\Debug\app.publish\setup.exe with error 800700C1
    錯誤: 無法發行,因為無法建置專案。

    2015年8月27日 上午 03:41
  • 錯誤如果變成專案建置失敗, 請使用滑鼠右鍵點選[方案總管]的專案名稱, 執行[重建]功能看看
    2015年8月27日 上午 10:36
  • Hi, tihs 重建沒問題, 是發行才出現問題 

    2015年8月28日 上午 12:26
  • 你有看到那篇下面這段嗎?

    新版的 Visual Studio 不包含舊版安裝元件,你若選擇舊版元件,必須自己拷貝進去,才會在必要元件中出現。


    先前 [VS2013] 更新封裝部署安裝檔 是把 VS2013 的安裝檔更新到 VS2010 去,這次是反過來把 VS2010 的安裝檔更新到 VS2013 的 Windows SDK v8.1a 去。

    包含舊版的必要條件

    包含舊版的必要條件


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2015年8月28日 下午 03:09
  • 這裡設定是對的, 只好重灌


    • 已編輯 TSAI3 2015年8月31日 上午 09:35
    2015年8月31日 上午 09:34
  • 我的封裝部署環境都沒問題,沒辦法重現你的狀況。

    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2015年9月4日 上午 09:40