none
VS2008 SP1啟動時套件載入失敗,程式Debug出錯 RRS feed

  • 問題

  • 請教大家一下,我的環境為Win7 x64 Sp1 + vs2008 Sp1,
     
    在啟動vs2008時出現套件載入失敗的錯誤信息:
     
    1.無法正確載入套件 'Microsoft Analysis Services Designer' (GUID={EABA99F3-7341-4105-8A3F-1C4F3955C4FC}. 請聯繫軟體供應商以尋求協助。由於可能發生環境撕毀,建議重新啟動應用程式。日後是否要停用載入此套件?您可以使用 'devenv /resetskippkgs' 來重新啟用套件載入。
     
     
     
    2.無法正確載入套件 'Microsoft Data Transformation Services Designer' (GUID={96B36E93-F71C-4160-A4EA-26AE801D2F63}. 請聯繫軟體供應商以尋求協助。由於可能發生環境撕毀,建議重新啟動應用程式。日後是否要停用載入此套件?您可以使用 'devenv /resetskippkgs' 來重新啟用套件載入。
     
     
     
    3.無法正確載入套件 'ReportDesignerPackage' (GUID={11B8C903-8FFD-4DFC-87CE-F6A82D77AF6B}. 請聯繫軟體供應商以尋求協助。由於可能發生環境撕毀,建議重新啟動應用程式。日後是否要停用載入此套件?您可以使用 'devenv /resetskippkgs' 來重新啟用套件載入。
     
     
     
    上面3個套件載入失敗,導致後面程式進行Debug時都沒法正常進行,一直出錯,
     
    我嘗試過把vs2008刪除重新安裝,問題依舊,不知大家有沒碰到過此情況,怎樣能解決?

    honwing
    2011年7月31日 上午 02:22

解答

  • 你可以試著解除安裝 SQL Server 中的 Business Intelligence Development Studio,因為這三個套件都是該元件的一部份。
    小朱的技術隨手寫:http://www.dotblogs.com.tw/regionbbs/
    雲端學堂Facebook: http://www.facebook.com/studyazure
    • 已標示為解答 honwing 2011年8月2日 下午 12:25
    2011年7月31日 上午 03:52
    版主
  • 從錯誤訊息來看, 應該是:

    物件.addEventListener(..);

    其中的物件為null引起的, 此錯誤是否和被停用的套用的功能有關? 如果沒有, 應該是程式自己的錯誤

    • 已標示為解答 honwing 2011年8月2日 下午 12:26
    2011年8月2日 上午 03:13
  • 感謝大家的熱心幫助,提供給我參考的依據,現在我已找到問題點所在,竟然是Java Jre的關係,刪除重新安裝 jre-6u26-windows-i586-s 就解決Debug的問題了,

    再次感謝。


    honwing
    • 已標示為解答 honwing 2011年8月2日 下午 12:25
    2011年8月2日 下午 12:25

所有回覆

  • 你可以試著解除安裝 SQL Server 中的 Business Intelligence Development Studio,因為這三個套件都是該元件的一部份。
    小朱的技術隨手寫:http://www.dotblogs.com.tw/regionbbs/
    雲端學堂Facebook: http://www.facebook.com/studyazure
    • 已標示為解答 honwing 2011年8月2日 下午 12:25
    2011年7月31日 上午 03:52
    版主
  • 您可以在看到這三個套件的停用詢問時, 先將套件停用, Visual Studio應該可以正常工作, 之前遇過這樣的狀況是在安裝Visual Studio的Service pack之後發生的
    2011年8月1日 上午 04:26
  • 移除之後啟動Visual Studio 2008時不會出錯誤提示了,不過Debug我的ASP .NET程式會出現以下的提示:

    [Microsoft JScript 執行階段錯誤: 無法取得屬性 'addEventListener' 的值: 物件為 null 或未經定義]

    確定我的專案之前Debug時是正常的。

    感謝小朱老師的熱心回覆。


    honwing

    • 已編輯 honwing 2011年8月2日 上午 04:49
    2011年8月1日 下午 12:11
  • 選擇停用元件,Visual Studio在啟動時是不會出錯誤信息,但在程式Debug時會出些莫名奇妙的錯誤,我確定之前的專案都能正常Debug的。

     


    honwing
    2011年8月1日 下午 12:13
  • 從錯誤訊息來看, 應該是:

    物件.addEventListener(..);

    其中的物件為null引起的, 此錯誤是否和被停用的套用的功能有關? 如果沒有, 應該是程式自己的錯誤

    • 已標示為解答 honwing 2011年8月2日 下午 12:26
    2011年8月2日 上午 03:13
  • 我自己裝了個VM來Debug調試正常,所以應該程式本身沒問題,現就是不知少了什麼東西。

     


    honwing
    2011年8月2日 上午 04:51
  • 感謝大家的熱心幫助,提供給我參考的依據,現在我已找到問題點所在,竟然是Java Jre的關係,刪除重新安裝 jre-6u26-windows-i586-s 就解決Debug的問題了,

    再次感謝。


    honwing
    • 已標示為解答 honwing 2011年8月2日 下午 12:25
    2011年8月2日 下午 12:25