none
升級sdf 檔需安裝的SQL SERVER 2000 Windows CE 2.0 找不到 RRS feed

解答

  • Hi!

    參考此網頁 資料庫升級工具 (SQL Server Compact)

    擷取其中內容

    資料庫升級工具的位置
    資料庫升級工具會當做 3.5 for Devices (SSCEDeviceRuntime-[lang].msi) MSI 檔的一部分,與 Visual Studio 2008 一起安裝。此檔案的預設位置為 %ProgramFiles%\Microsoft SQL Server Compact Edition\v3.5\Devices\[platform]\[processor]\upgrade.exe。

    我的Blog .NET菜鳥自救會
    2009年12月25日 下午 01:04
    版主
  • 我指的並不是這個耶
    而是在這個參考頁面中提到的

     
    執行資料庫升級工具

    <!---->

    若要執行資料庫升級工具,您必須在智慧型裝置上安裝下列軟體﹕

    • SQL Server CE (v. 2.0) 和 3.5/3.5 SP1

    這兒所提到的SQL Server CE (v. 2.0) ,我是這個找不到,所以只有升級工具,就一直升級不了

    在文章連結的頭一行
    "3.5 資料庫升級工具是一種可升級 SQL Server 2000 Windows CE Edition 2.0 (SQL Server CE 2.0) 資料庫的命令提示字元公用程式"

    他這邊指的是,如果你是想要在裝置上,把SQL Server CE 2.0升級到SQL Server CE(compact edition) 3.5 /3.5 SP1的話,那在裝置上要安裝2.0以及3.5 / 3.5 SP1的執行環境(Runtime)。

    SQL Server CE 2.0應該是相當早期的版本了,一些版本相關訊息可以在這邊看到
    http://support.microsoft.com/?scid=kb%3Ben-us%3B950550&x=9&y=13


    你要確認一下你舊版的SQL Server CE是那個版本的,SQL Server 2000 Windows CE 2.0這個目前在網站上似乎是已經找不到了,這個跟VS2003是綁一起的,如果你有裝VS2003,可以在下面位置找到
    C:\Program Files\Microsoft Visual Studio .NET 2003\CompactFrameworkSDK\v1.0.5000\Windows CE\

    請注意討論區相關規則,良好的討論環境需要大家共同努力、遵守
    • 已標示為解答 HankChiang 2009年12月28日 上午 05:58
    2009年12月28日 上午 05:52
    版主

所有回覆

  • Hi!

    參考此網頁 資料庫升級工具 (SQL Server Compact)

    擷取其中內容

    資料庫升級工具的位置
    資料庫升級工具會當做 3.5 for Devices (SSCEDeviceRuntime-[lang].msi) MSI 檔的一部分,與 Visual Studio 2008 一起安裝。此檔案的預設位置為 %ProgramFiles%\Microsoft SQL Server Compact Edition\v3.5\Devices\[platform]\[processor]\upgrade.exe。

    我的Blog .NET菜鳥自救會
    2009年12月25日 下午 01:04
    版主
  • 我指的並不是這個耶
    而是在這個參考頁面中提到的

     
    執行資料庫升級工具

    <!---->

    若要執行資料庫升級工具,您必須在智慧型裝置上安裝下列軟體﹕

    • SQL Server CE (v. 2.0) 和 3.5/3.5 SP1

    這兒所提到的SQL Server CE (v. 2.0) ,我是這個找不到,所以只有升級工具,就一直升級不了

    2009年12月28日 上午 04:36
  • 我指的並不是這個耶
    而是在這個參考頁面中提到的

     
    執行資料庫升級工具

    <!---->

    若要執行資料庫升級工具,您必須在智慧型裝置上安裝下列軟體﹕

    • SQL Server CE (v. 2.0) 和 3.5/3.5 SP1

    這兒所提到的SQL Server CE (v. 2.0) ,我是這個找不到,所以只有升級工具,就一直升級不了

    在文章連結的頭一行
    "3.5 資料庫升級工具是一種可升級 SQL Server 2000 Windows CE Edition 2.0 (SQL Server CE 2.0) 資料庫的命令提示字元公用程式"

    他這邊指的是,如果你是想要在裝置上,把SQL Server CE 2.0升級到SQL Server CE(compact edition) 3.5 /3.5 SP1的話,那在裝置上要安裝2.0以及3.5 / 3.5 SP1的執行環境(Runtime)。

    SQL Server CE 2.0應該是相當早期的版本了,一些版本相關訊息可以在這邊看到
    http://support.microsoft.com/?scid=kb%3Ben-us%3B950550&x=9&y=13


    你要確認一下你舊版的SQL Server CE是那個版本的,SQL Server 2000 Windows CE 2.0這個目前在網站上似乎是已經找不到了,這個跟VS2003是綁一起的,如果你有裝VS2003,可以在下面位置找到
    C:\Program Files\Microsoft Visual Studio .NET 2003\CompactFrameworkSDK\v1.0.5000\Windows CE\

    請注意討論區相關規則,良好的討論環境需要大家共同努力、遵守
    • 已標示為解答 HankChiang 2009年12月28日 上午 05:58
    2009年12月28日 上午 05:52
    版主
  • 感謝你的回覆,我去找2003來裝來試試了
    2009年12月28日 上午 05:59