none
我已經安裝 Visual Studio 2005 但是怎樣都無法安裝 SQL Express 2005 ? RRS feed

  • 問題

  • 大家好

    我已經安裝 Visual Studio 2005 但是怎樣都無法安裝 SQL Express 2005 ?

    他說要叫我先移除相關元件,我也都移除了,但安裝的時候,他還是說有元件衝突!

    2006年2月28日 上午 11:19

解答

  • 在 SQL Server 2005 Express 讀我檔案 :

    3.12 解除安裝 SQL Server Express 及 Visual Studio 2005 的發行前版本

    在安裝之前,您必須移除所有舊版的 SQL Server Express、Visual Studio 2005 及 .NET Framework 2.0。因為這兩種產品均相依於同一版本的 .NET Framework,所以必須依下列順序解除安裝:

    • SQL Server Express
    • Visual Studio 2005
    • .NET Framework 2.0

    這表示你的電腦中有舊版的元件存在,你可能要先移除掉它,包括 Beta-2, CTP 等,RC 版應該也算 ...

    2006年3月3日 上午 07:57
    版主

所有回覆

  • 你看看有沒有跟我先前碰到的狀況相同,若是一樣,可以跟我用相同方法處理:

    http://spaces.msn.com/tlcheng/blog/cns!145419920BFD55A7!661.entry

    若不一樣,建議你把詳細錯誤訊息貼出來,跟你的處理方式,這樣大家才能參考。

    2006年2月28日 下午 12:42
    版主
  • 狀況不太一樣。

    錯誤訊息如下:

    SQL Swerver 2005 安裝程式偵測到有不相容之Visual Studio、.Net Framework 或 SQL Server 2005 的Beta版元件。請使用「新增或移除程式」來移除這些元件,然後重新執行 SQL Server 2005 安裝程式。如需解除安裝 SQL Server 2005的詳細指示,請參閱 SQL Server 2005讀我檔案。

    2006年3月1日 上午 02:01
  • 在 SQL Server 2005 Express 讀我檔案 :

    3.12 解除安裝 SQL Server Express 及 Visual Studio 2005 的發行前版本

    在安裝之前,您必須移除所有舊版的 SQL Server Express、Visual Studio 2005 及 .NET Framework 2.0。因為這兩種產品均相依於同一版本的 .NET Framework,所以必須依下列順序解除安裝:

    • SQL Server Express
    • Visual Studio 2005
    • .NET Framework 2.0

    這表示你的電腦中有舊版的元件存在,你可能要先移除掉它,包括 Beta-2, CTP 等,RC 版應該也算 ...

    2006年3月3日 上午 07:57
    版主