none
同一台機器跑win 7 pro,cpu的虛擬化VT-X都是開啟的,跑win 10 pro,cpu的虛擬化VT-X都是關閉的 RRS feed

  • 問題

  • 你好,我在開發程式的時候
    會用到visual studio xamarin開發android app會用到虛擬化
    同一台機器用win 7 pro開發
    用各式虛擬化偵測工具Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V偵測
    cpu的虛擬化VT-X都是開啟的
    用了win 10 pro後
    用各式虛擬化偵測工具Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V偵測
    cpu的虛擬化VT-X都是關閉的
    visual studio xamarin跑android模擬器出現了各式各樣怪問題問題, P.S.WIN 7 PRO和WIN 10 PRO用的是同一台電腦
    請問這是win 10有問題嗎
    2019年9月13日 上午 04:29

所有回覆

  • Windows 10在2018 April Update後多了一項Windows Hypervisor Platform, 如果未使用這一項, 也可以使用Intel HAXM(可以透過Visual Studio Installer安裝), 都可以加速Android模擬器, 如果有裝其中一項, 應該可以偵測到
    2019年9月13日 上午 08:36
  • 在Win 10 pro下Hypervisor Platform 和Intel HAXM這兩個我當然都有安裝,
    但虛擬化偵測工具Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V
    都顯示虛擬化VT-X未啟用
    你使用Xamarin有遇到問題嗎
    問題是跑android模擬器時一訂要加fastboot.forceColdBoot=yes和fastboot.forceFastBoot=no
    模擬器才能跑,但相對的模擬器每次都要重開機,所以開模擬器很慢
    還有模擬器呼叫WCF時,當呼叫到thread時,都會出現system error,
    Thread的程式碼是加入連線服務WCF自動產生的,Thread的程式碼好像是需要跑虛擬化VT-X的
    我另外寫了一隻win form呼叫同樣的WCF,都可以成功的回傳資料
    我真的懷疑是WIN 10的 BUG,別人用Xamarin在win 10下跑也會遇到類似的問題嗎
    2019年9月13日 上午 11:39
  • 1) 您可以只安裝INTEL HAXM, 不要安裝Hypervisor Platform再試看看
    2) 我跑Xamarin+Android模擬器沒有什麼問題
    3) 我是呼叫Web API, 沒有呼叫WCF, 也可以正常執行
    2019年9月13日 下午 11:15
  • 如果 Win10 環境有啟用了 Hyper-V,
    再用檢查工具檢查虛擬化支援,顯示為關閉則是正常的狀況,
    因為虛擬化資源已經被 Hyper-V 獨占使用

    另外,也請避免使用粗體字及跨不同的微軟論壇發文


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部

    論壇不是神壇,沒人會通靈知道問題狀況
    請正確簡述標題及詳述狀況
    如何在論壇正確發問,可以參考iThome的文章:
    如何問到我要的答案

    2019年9月14日 上午 03:27
  • 你好,我移除了hyper-v所有元件,用Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V跑
    還是顯示虛擬化VT-X未啟用
    再加碼移除虛擬機器平台,用Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V跑
    還是顯示虛擬化VT-X未啟用
    2019年9月15日 上午 08:32
  • 你好,我移除了Hypervisor Platform元件,用Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V跑
    還是顯示虛擬化VT-X未啟用,
    跑visual studio 2019 Xamarin還是會出現那些問題
    2019年9月15日 上午 09:11
  • 您有安裝Intel HAXM這一項嗎?
    2019年9月16日 上午 12:32
  • 你好,visual studio installer有Intel HAXM這個選項可供安裝

    我有打勾安裝Intel HAXM

    2019年9月16日 上午 01:07
  • 我用Intel(R) Processor Identification Utility查了一下, 的確沒有顯示有啟用CPU虛擬化, 不過只要Android模擬器啟動時沒有顯示未啟用VT-X的警示畫面, 而且模擬器能夠快速啟動, 應該是己經確定啟用CPU虛擬化了
    2019年9月16日 上午 05:51
  • 你好,同一台機器在win 7 下Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V測

    cpu的虛擬化VT-X都是開啟的

    且跑Android模擬器非常快速,沒有任何問題

    但同一台機器在win 10 下Intel(R) Processor Identification Utility,securable,LeoMoon CPU-V測

    cpu的虛擬化VT-X都是關閉的的

    且跑Android模擬器非常慢,定要加fastboot.forceColdBoot=yes和fastboot.forceFastBoot=no
    模擬器才能跑,但相對的模擬器每次都要重開機,所以開模擬器很慢

    2019年9月16日 上午 11:24
  • Android模擬器啟動很慢表示虛擬化未啟用, 我的設定是這樣:

    1) BOIS設定CPU虛擬化啟用

    2) 不裝Hyper-V, Windows Hypervisor Platform, Virtual Machine Platform, 只裝Intel HAXM

    Android模擬器啟動很快, 也不需要重開機

    2019年9月17日 上午 12:21
  • 我win 10這樣設卻不行只有win 7才跑得快

    可不可以請你們向上回報,不然我沒機會用win 10

    2019年9月17日 上午 11:52
  • 忘了問, 您的電腦會不會是配備AMD CPU?
    2019年9月17日 下午 12:30
  • 你好,是intel i7 3770
    2019年9月17日 下午 12:45
  • 我win 10這樣設卻不行只有win 7才跑得快

    可不可以請你們向上回報,不然我沒機會用win 10

    你的電腦還有安裝其他類似的虛擬化軟體嗎?
    像是 VMWare 或是 VirtualBox?

    另外,這裡出沒的幾乎都是熱情參與討論的網友,
    如果想找官方人員向上回報,建議您直接聯繫微軟客服付費建案,
    先請求技術支援服務先確認您的電腦狀況


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部

    論壇不是神壇,沒人會通靈知道問題狀況
    請正確簡述標題及詳述狀況
    如何在論壇正確發問,可以參考iThome的文章:
    如何問到我要的答案

    2019年9月17日 下午 01:19
  • 那就只能懷疑BIOS的CPU虛擬化沒有啟用了
    2019年9月18日 上午 12:43
  • 你好,沒有裝VMWare 或是 VirtualBox等虛擬化軟體

    環境很乾淨,只有裝sql server 和visual studio 2019這兩樣

    2019年9月18日 上午 04:07