none
.NET Framework 不支援 Windows Server 2003 64bit ? RRS feed

解答

  • 網站寫的不支援意思是說Windows Server 2003 x64 Edition安裝後不會像Windows Server 2003 x86 Edition的作業系統中預設就安裝了.NET Framework 1.1, 而且.NET Framework 2.0之後分了兩個版本, 一個是.NET Framework 2.0 for x86與.NET Framework 2.0 for x64的版本, 因此, 你只能安裝.NET Framework 2.0 for x64版本在WinSrv 2003 x64 Edition上頭, 而安裝Framework 2.0 for x86版本, 它會跟你說不支援這個作業系統.

    不過有點需要特別注意的是, 安裝.Net Framework 1.1 結束之後, 它會跟安裝x86的情況一樣會安裝在%WinDir%\Microsoft.Net\Framework\v1.1.4322 目錄中, 而安裝.Net Framework 2.0 for x64 版本的話, 會在%WinDir%\Microsoft.Net\Framework\v2.0.50727與%WinDir%\Microsoft.Net\Framework64\v2.0.50727建立這兩個目錄, 其分別支援x86與x64版本的應用程式, 也就是說, 你裝了Framework 2.0 for x64版本, 其實也就是裝了Framework 2.0 x86與x64, @@, (好像有點給它複雜), 不過, 你可以在x64作業系統, 跑x86的應用程式, 也可以跑x64的應用程式

     

    2006年4月17日 上午 07:46

所有回覆

  • .Net 2.0 才有 64 bit 的版本。
    .Net 1.1/2.0 x86 可以安裝在 Win2003 x64 上,安裝的時候會有對話框告訴你要看哪個文件,裡面文件中有說如何安裝。

    因為只有安裝的時候會說,看過就忘了,照著做就可以了。

    我裝過 .Net 1.1 在 Win2003 x64 上。

    你引用的網頁最上面有日期,那是 2002 年的,跟現況頗有不同~

    2006年4月17日 上午 07:06
  • 網站寫的不支援意思是說Windows Server 2003 x64 Edition安裝後不會像Windows Server 2003 x86 Edition的作業系統中預設就安裝了.NET Framework 1.1, 而且.NET Framework 2.0之後分了兩個版本, 一個是.NET Framework 2.0 for x86與.NET Framework 2.0 for x64的版本, 因此, 你只能安裝.NET Framework 2.0 for x64版本在WinSrv 2003 x64 Edition上頭, 而安裝Framework 2.0 for x86版本, 它會跟你說不支援這個作業系統.

    不過有點需要特別注意的是, 安裝.Net Framework 1.1 結束之後, 它會跟安裝x86的情況一樣會安裝在%WinDir%\Microsoft.Net\Framework\v1.1.4322 目錄中, 而安裝.Net Framework 2.0 for x64 版本的話, 會在%WinDir%\Microsoft.Net\Framework\v2.0.50727與%WinDir%\Microsoft.Net\Framework64\v2.0.50727建立這兩個目錄, 其分別支援x86與x64版本的應用程式, 也就是說, 你裝了Framework 2.0 for x64版本, 其實也就是裝了Framework 2.0 x86與x64, @@, (好像有點給它複雜), 不過, 你可以在x64作業系統, 跑x86的應用程式, 也可以跑x64的應用程式

     

    2006年4月17日 上午 07:46