none
driver_irql_not_less_or_equal (tcpip.sys) RRS feed

  • 問題

  • 各位前輩好,小弟遇到了一個無解的問題,請各位前輩幫幫我一下

    感謝各位前輩!

    最近在使用Visual Studio 2012 實做 WebForm時,不管弄到哪個網頁,用一陣子就會藍屏

    小弟的系統是Windows 8,電腦是最近才剛買的

    藍屏的代碼只顯示"driver_irql_not_less_or_equal (tcpip.sys)"

    查了論壇似乎沒人遇到這問題...還是我關鍵字茶錯了呢??

    請教各位前輩,感激不盡!

    每次編輯完再做DeBug時都超怕藍屏,但就算怕...也是會發生= ="

    2012年12月9日 下午 03:08

解答

  • 您好

    請更新你的網卡驅動程式,參考 關於 0x000000D1 : DRIVER_IRQL_NOT_LESS_OR_EQUAL

    另外,移除您自行安裝的防毒軟體與防火牆軟體,再測試看看


    歡迎參觀我的Blog【菜鳥自救會】 【粉絲專頁】

    • 已提議為解答 ChenBruceModerator 2012年12月13日 上午 03:43
    • 已取消提議為解答 Sun Pig 2012年12月13日 上午 03:48
    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:26
    2012年12月10日 上午 01:25
  • 您好,

    可試著以下的方式來分析看看,

    1.看一下事件顯示器中是否有比較詳細的訊息。

    2.將AVG 2013防毒先關掉,然後再試一下程式

    3.測試的方式是用VS.NET Debug起來執行,還是直接開網頁執行呢? Debug or 直接開網頁都會當嗎? VS.NET 有以系統管理者身份執行嗎?

    4.那支網頁有比較特別的程式嗎? 一run起來就當,還是run到某個地方才當呢?


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/

    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:26
    2012年12月14日 上午 01:42
  • 您好,

    那是否在開啟該專案時,先透過「擴充管理員」先將您有安裝的擴充停用,再試一次呢?

    是否在事件顯示器會有Log呢?

    另外,是否有將防毒的先移除再試看看呢?

    TCPIP.sys 0x000000D1 DRIVER_IRQL_NOT_LESS_OR_EQUAL

     


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/



    • 已編輯 亂馬客 2012年12月16日 上午 12:50
    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:27
    2012年12月16日 上午 12:45
  • 您好,

    那個錯誤,就像小歐大大說的,好像是網路的問題。

    網路search有人提到有安裝avg。

    因為有時防毒軟體會與某些ap去存取網路時衝到,而造成系統當機。

    小弟使用win8安裝nod防毒時,有安裝某牌的ssl vpn,結果造成一直當機的情形,後來將ssl vpn移除後才正常。

    因為資訊不多,所以只好將可疑的地方移除試看看。

    如果覺得是裝了vs2012 update1才發生的,就可以試著將update 1移除。或是重裝vs2012別上update1試看看。

    也可以上 http://connect.microsoft.com/VisualStudio 反應問題哦!


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/

    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:27
    2012年12月16日 上午 09:21

所有回覆

  • 您好

    請更新你的網卡驅動程式,參考 關於 0x000000D1 : DRIVER_IRQL_NOT_LESS_OR_EQUAL

    另外,移除您自行安裝的防毒軟體與防火牆軟體,再測試看看


    歡迎參觀我的Blog【菜鳥自救會】 【粉絲專頁】

    • 已提議為解答 ChenBruceModerator 2012年12月13日 上午 03:43
    • 已取消提議為解答 Sun Pig 2012年12月13日 上午 03:48
    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:26
    2012年12月10日 上午 01:25
  • 感謝 小歐ou 前輩的回答

    因為最近沒空開那台有問題的電腦,所以拖到現在才回答

    我並不是問到答案就跑的人唷...

    剛剛把驅動更新,但卻顯示已經是最新的...

    於是...我又跑了一次那個程式...又掛掉

    請問還有其他的解決方法嗎??

    不好意思  拖到現在才回復  感謝小歐ou 前輩

    2012年12月13日 上午 03:48
  •  又跑了一次那個程式...又掛掉


    請問只有那個程式會掛嗎?

    還是所有的呢?

    是否有裝什麼防毒軟體呢?


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/

    2012年12月13日 上午 10:12
  • 感謝 亂馬客 前輩的回覆

    目前只有那隻程式能測試,所以也不太清楚是不是其他的就沒問題

    有灌防毒:AVG 2013

    2012年12月13日 上午 11:35
  • 您好,

    可試著以下的方式來分析看看,

    1.看一下事件顯示器中是否有比較詳細的訊息。

    2.將AVG 2013防毒先關掉,然後再試一下程式

    3.測試的方式是用VS.NET Debug起來執行,還是直接開網頁執行呢? Debug or 直接開網頁都會當嗎? VS.NET 有以系統管理者身份執行嗎?

    4.那支網頁有比較特別的程式嗎? 一run起來就當,還是run到某個地方才當呢?


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/

    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:26
    2012年12月14日 上午 01:42
  • 上次就是出現這個畫面,過沒多久就藍屏了= =+
    • 已編輯 Sun Pig 2012年12月14日 下午 06:44
    2012年12月14日 下午 06:43
  • 那這個檔案你檢查的結果為何?

    論壇是網友平等互助 保證解答請至 微軟技術支援服務


    提問時,錯誤情境描述與錯誤訊息很重要,情境描述包含你做了什麼,預期的結果與實際發生的結果。一個最爛的問法範例:「我的電腦電腦怎麼不能開機?」誰知道你家是不是沒電還是你根本找不到電源鈕。

    2012年12月15日 上午 08:48
  • 感謝心冷熱情熄前輩的回復

    老實說,看了N次還是看不出個所以然

    這個檔的內容似乎只記錄前一天或者當天的...前幾次都被系統自動蓋過去了...沒發現牠的蹤跡= ="

    這是這個檔的片段,希望能提供前輩分析,早日找出元兇><"

    <entry>
        <record>2</record>
        <time>2012/12/14 18:25:07.635</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Running in User Groups: Users</description>
    </entry>

    2012年12月15日 下午 02:49
  • 您好,

    那是否在開啟該專案時,先透過「擴充管理員」先將您有安裝的擴充停用,再試一次呢?

    是否在事件顯示器會有Log呢?

    另外,是否有將防毒的先移除再試看看呢?

    TCPIP.sys 0x000000D1 DRIVER_IRQL_NOT_LESS_OR_EQUAL

     


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/



    • 已編輯 亂馬客 2012年12月16日 上午 12:50
    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:27
    2012年12月16日 上午 12:45
  • 感謝 亂馬客 前輩的回復

    這是小弟目前裝的擴充元件

    至於LOG檔...上次發生的時間有點久遠,忘記是哪天發生的了

    用VS 2010時也是用這套防毒(AVG),好像沒遇過這情況

    好像是改用VS2012 又剛好裝 update 1 時 才遇到這情況

    2012年12月16日 上午 05:46
  • 您好,

    那個錯誤,就像小歐大大說的,好像是網路的問題。

    網路search有人提到有安裝avg。

    因為有時防毒軟體會與某些ap去存取網路時衝到,而造成系統當機。

    小弟使用win8安裝nod防毒時,有安裝某牌的ssl vpn,結果造成一直當機的情形,後來將ssl vpn移除後才正常。

    因為資訊不多,所以只好將可疑的地方移除試看看。

    如果覺得是裝了vs2012 update1才發生的,就可以試著將update 1移除。或是重裝vs2012別上update1試看看。

    也可以上 http://connect.microsoft.com/VisualStudio 反應問題哦!


    以上說明若有錯誤請指教,謝謝。
    亂馬客blog: http://www.dotblogs.com.tw/rainmaker/

    • 已標示為解答 Sun Pig 2012年12月16日 上午 09:27
    2012年12月16日 上午 09:21
  • 感謝 亂馬客 前輩的回復

    看來只能重裝試看看了...  :(

    每次開發專案編開發就要邊擔心是不是下一秒就會當機

    提心吊膽...

    感謝各位前輩熱烈的回覆

    2012年12月16日 上午 09:26