none
一个非常痛苦的问题! RRS feed

  • 问题

  • 用VS2008做vb.net的程序,现在需要在别的机器上安装.
    需要安装.net framework 3.5,文件超级大,安装下载非常痛苦!!!
    网上下载不现实,客户坚决不答应!!! 
    只有打包进安装文件,但是也很占用安装时间,打包后安装文件超级巨大,等于重装了一次操作系统,漫长的安装过程,除了痛苦还是痛苦!!!! 问题是我的程序只用了很少几个.net程序集,很多程序集对我根本没用。
    请问一下,有没有什么办法,能让我只安装需要的.net程序集?
    各位大佬,谁能帮我?!
    2009年11月4日 2:35

答案

  • VS2008可以设置你的程序编译成什么版本的,你可以选择目标框架为。net 2.0,在工程属性里面设置

    前提是你不能使用.net 2.0以后的东西

    【孟子E章】
    2009年11月4日 5:12
    版主
  • 要确认你引用的功能是不是3.5的


    如果你建立工程的时候  在工程右上角选择 .net framework 2.0  基本上 也可以运行的话    那么就可以在这种状态下编译成2.0依赖的程序


    成为 Microsoft V Dash了。。。
    2009年11月4日 5:43
    版主
  • 你好!
         可以尝试.NET Framework Client Profile:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=8cea6cd1-15bc-4664-b27d-8ceba808b28b&displaylang=zh-cn
    周雪峰
    2009年11月4日 11:14
    版主

全部回复

  • VS2008可以设置你的程序编译成什么版本的,你可以选择目标框架为。net 2.0,在工程属性里面设置

    前提是你不能使用.net 2.0以后的东西

    【孟子E章】
    2009年11月4日 5:12
    版主
  • .net framework 要装,就得一起装,依据版本不同,装的大小不同.

    我只能想到不安装.net 程序集方法,那就是让客户使用windows 7操作系统.

    2009年11月4日 5:36
  • 要确认你引用的功能是不是3.5的


    如果你建立工程的时候  在工程右上角选择 .net framework 2.0  基本上 也可以运行的话    那么就可以在这种状态下编译成2.0依赖的程序


    成为 Microsoft V Dash了。。。
    2009年11月4日 5:43
    版主
  • 我看只有期待以后全民win 7吧

    到时候.net编程意义就不同了

    徐培华
    2009年11月4日 5:57
  • 你好!
         可以尝试.NET Framework Client Profile:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=8cea6cd1-15bc-4664-b27d-8ceba808b28b&displaylang=zh-cn
    周雪峰
    2009年11月4日 11:14
    版主