none
WEB相关 RRS feed

  • 问题

  • 1.如何将XP系统上的IIS升级?
    2.如何在IIS中加入ASP.NET3.5, 3.0?(目前只有2.0和1.0)
    3.CSharp可以使用中文变量名?其它语言也可以吗?使用中文变量名有何优劣?
    4.常用的.NET类库有哪些?用不用刻意的去记这些类库?

    Never bend, never break, never back down!
    • 已移动 孟宪会Moderator 2009年9月14日 14:02 (发件人:.NET Framework 一般性问题讨论区)
    2009年9月14日 7:50

答案

  • 你好
    1,不同的系统只能安装本系统对应的IIS,这个是无法升级的
    windows 2000 server  对应 IIS 5.0
    windows XP 对应 IIS 5.1
    windows server 2003 对应IIS 6.0
    Windows Vista 是iis7.0
    Windows server 2008 也是IIS 7.0
    2,首先请安装.net framework 3.5 安装后会自动注册到IIS
    http://www.microsoft.com/downloads/details.aspx?familyid=333325fd-ae52-4e35-b531-508d977d32a6&displaylang=zh-cn
    3,一般是在很多Winform程序中使用了很多中文变量名,个人不建议使用中文变量名,这样整个程序可读性等方面很糟糕
    4,类库里边的类一般都是常用的 只是不同的领域不同的情况下使用不同
    System下面的那些基本类型
    System.Xml处理Xml
    System.Text文本处理
    System.Net跟网络相关等
    System.IO
    System.Data
    .....
    不用刻意去记,用的多了自然就记住了
    如果最开始不清楚哪些类有哪些功能,可以查阅一些介绍类库的书
    一般命名空间跟这个下面的类是相符合的 比如我要操作数据表DataTable则是System.Data 还有字命名空间比如System.Data.SqlClient等


    Wenn ich dich hab’,gibt es nichts, was unerträglich ist.坚持不懈!http://hi.baidu.com/1987raymond
    • 已标记为答案 Sven K 2009年9月15日 7:56
    2009年9月14日 8:20
    版主

全部回复

  • 你好
    1,不同的系统只能安装本系统对应的IIS,这个是无法升级的
    windows 2000 server  对应 IIS 5.0
    windows XP 对应 IIS 5.1
    windows server 2003 对应IIS 6.0
    Windows Vista 是iis7.0
    Windows server 2008 也是IIS 7.0
    2,首先请安装.net framework 3.5 安装后会自动注册到IIS
    http://www.microsoft.com/downloads/details.aspx?familyid=333325fd-ae52-4e35-b531-508d977d32a6&displaylang=zh-cn
    3,一般是在很多Winform程序中使用了很多中文变量名,个人不建议使用中文变量名,这样整个程序可读性等方面很糟糕
    4,类库里边的类一般都是常用的 只是不同的领域不同的情况下使用不同
    System下面的那些基本类型
    System.Xml处理Xml
    System.Text文本处理
    System.Net跟网络相关等
    System.IO
    System.Data
    .....
    不用刻意去记,用的多了自然就记住了
    如果最开始不清楚哪些类有哪些功能,可以查阅一些介绍类库的书
    一般命名空间跟这个下面的类是相符合的 比如我要操作数据表DataTable则是System.Data 还有字命名空间比如System.Data.SqlClient等


    Wenn ich dich hab’,gibt es nichts, was unerträglich ist.坚持不懈!http://hi.baidu.com/1987raymond
    • 已标记为答案 Sven K 2009年9月15日 7:56
    2009年9月14日 8:20
    版主
  • 你好,

    1、Xp升级,你可以到微软网站下载相关补丁进行升级。Xp只能安装5.1,2003安装6.0,Vista安装7.0,无法逾越!

    2、安装ASP.NET3.5自动会配置与IIS的关系,你不需要操作什么,如果你想重新关联,可以使用asp_regiis来重新设置,IIS上有版本选择,这个可能是你唯一需要做的。

    3、我不知道其他语言在中文支持好不好,但是,个人不建议使用中文作为变量名。C#对于中文变量名编译是通过的。

    4、.NET 常用类库很多,大概分为几类,文件操作,数据库操作,注册表操作,网络操作,图形图像操作,文本操作等等,另外,我记得有位版主的签名上面写了,理解的越多,需要记忆的就越少。忘记哪位了,看见我的留言,估计会站出来。
    jon.valett@gmail.com
    2009年9月14日 8:20
    版主
  • 你好!
         1,无法升级,一个版本的操作系统对应一个版本的
         2,你安装.NET Framework3.5或VS2008会自动帮你注册的
         3,可以使用中文的变量名,其他.NET语言也可以,使用中文变量名只能获得一些可读性方面的改善,通常这种改善没有实际意义!
         4,.NET 中自带了类库了,常用的类需要掌握!
    周雪峰
    2009年9月14日 12:16
  • ASP.NET3.5, 3.0只是.NET版本号,真正的iis里是没有asp.net 3.5,3.0这些版本的,以后iis7之后会有asp.net 4.0,之前会有asp.net2.0,1.1,1.0这些版本.NET 3.5, 3.0对asp.net没有太多的升级
    【孟子E章】
    2009年9月14日 14:01
    版主
  • 感谢各位的帮助!
    孟大哥说的很对,IIS里确实没有3.0和3.5。
    Never bend, never break, never back down!
    2009年9月15日 7:57