none
Win10 系统如何安装 Net Framework 4.5? RRS feed

  • 问题

  • win10系统自带Net Framework 4.7,在运行SAP软件的时候提示需要安装Net Framework 4.5版本,进行系统安装显示已安装更高版本软件,本人尝试了net framework clean软件但还是不能删除4.7版本,请问如何能解决以上冲突,谢谢!
    2017年11月1日 1:26

全部回复

  • 按理说,装好了4.7,以4.5编译的程序可以直接运行。

    https://stackoverflow.com/questions/35733040/how-to-install-net-4-framework-in-windows-10

    From the download page for the "Microsoft .NET Framework 4.6" (emphasis mine):

    The Microsoft .NET Framework 4.6 is a highly compatible, in-place update to the Microsoft .NET Framework 4, Microsoft .NET Framework 4.5, Microsoft .NET Framework 4.5.1 and Microsoft .NET Framework 4.5.2.

    On other words, having .NET 4.6 installed (it's part of Windows 10 so you need not manually install it) means you have .NET 4.0, 4.5, 4.5.1, 4.5.2 and 4.6 installed and can run code targeting any of those framework versions without making any modifications to your Windows installation.

    You cannot install .NET 4.0 when you have a later version installed as each version is an in-place update to the last.


    If, however, your problem is with opening a project which targets .NET 4.0.1, 4.0.2, or 4.0.3 in Visual Studio on Windows 10, you may need to download one of the targeting packs:

    as I'm not sure they are installed.

    需要阅读下SAP软件安装要求。


    专注于.NET ERP/CRM开发框架,C/S架构,SQL Server + ORM(LLBL Gen Pro) + Infragistics WinForms

    2017年11月2日 0:59
  • .net Framework 4.X 版本都是向下兼容彼此取代的关系,这与 3.5 跟 4.X 可以共存的关系还不一样。在已预装 4.7 的 Windows 10 系统中已无法退回  4.5。


    Alexis Zhang

    http://mvp.microsoft.com/zh-cn/mvp/Jie%20Zhang-4000545
    http://blogs.itecn.net/blogs/alexis

    推荐以 NNTP Bridge 桥接新闻组方式访问论坛。

    本帖是回复帖,原帖作者是楼上的 <HZcl.C>;

    | win10系统自带Net Framework 4.7,在运行SAP软件的时候提示需要安装Net Framework 4.5版本,进行系统安装显示已安装更高版本软件,本人尝试了net framework clean软件但还是不能删除4.7版本,请问如何能解决以上冲突,谢谢!

    2017年11月2日 14:07
    版主