none
VS2010的WebApplication项目无法添加项 RRS feed

答案

  • Hi Euhayuu,

    Welcome to the MSDN forum.

    建议你尝试下新建一个web application看看能不能添加项。如果不行的话,尝试用管理员运行VS再试下。还是不行的话,检查下是否有安装Visual Studio的插件,并在Visual Studio 命令提示行中输入devenv /Resetsettings, devenv /Safemode来启动IDE看看。

    另外,推荐一个非常有用的工具:Process Monitor,这个工具可以用来捕获存取文件/注册表的访问记录。可以使用进程名devenv.exe来过滤结果结果,这样可以只看到相关的列表。这样我们可以检查问题发生时,是哪一个注册表键/文件拒绝访问。

    Have a nice day.


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • 已标记为答案 Euhayuu 2012年5月15日 1:14
    2012年5月11日 7:18

全部回复

  • 试试 重启VS或者机器 再次打开项目试试


    爱吃西瓜的小强[mcpd]

    2012年5月10日 8:37
  • 不行的..重装VS也不行
    • 已编辑 Euhayuu 2012年5月11日 4:46
    2012年5月10日 9:09
  • Hi Euhayuu,

    Welcome to the MSDN forum.

    建议你尝试下新建一个web application看看能不能添加项。如果不行的话,尝试用管理员运行VS再试下。还是不行的话,检查下是否有安装Visual Studio的插件,并在Visual Studio 命令提示行中输入devenv /Resetsettings, devenv /Safemode来启动IDE看看。

    另外,推荐一个非常有用的工具:Process Monitor,这个工具可以用来捕获存取文件/注册表的访问记录。可以使用进程名devenv.exe来过滤结果结果,这样可以只看到相关的列表。这样我们可以检查问题发生时,是哪一个注册表键/文件拒绝访问。

    Have a nice day.


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • 已标记为答案 Euhayuu 2012年5月15日 1:14
    2012年5月11日 7:18
  • 你好,我刚才尝试重新新建一个web application,结果直接就报错"不允许所请求的注册表访问权"了.然后用管理员运行运行和你给出的2个命令运行,都是同样的结果.VS上安装的Dev控件我也已经卸载了.

    前几天新建web application的时候都没有任何问题,前两天突然就遇到这样的情况,期间我并没有在VS上进行过任何插件的安装,实在不知道是怎么回事


    2012年5月11日 8:49
  • 你的windows账户是管理员权限吗?我以前也遇到过这种情况,是因为用了非超级管理员账户
    2012年5月11日 8:53
  • 应该不是windows账户问题吧,因为就在周一我还新建WebApplication项目后添加网页进行过编写,但是周3我从SVN上检出同事提供的WebApplication项目想要添加页面的时候就遇到了这样的问题,难道是因为SVN的关系?

    我把SVN卸载了然后重装VS还是不行啊orz

    • 已编辑 Euhayuu 2012年5月12日 0:40
    2012年5月11日 9:02
  • 感谢大家的帮助,我还是老老实实重装去了..
    2012年5月15日 1:14