locked
显卡无法正确安装 RRS feed

  • 问题

  • 芯片组驱动、声卡驱动都可以安装成功,但是安装显卡驱动的时候出现错误,无法正确安装,以下内容是.log文件的,大家帮忙看下是什么原因。谢谢

    ********** S3 GRAPHICS SETUP LOG - Started 2007/01/04 4:22:29 **********

             *****  Please scroll to the end of *****
            ***** this document for the results. *****

    S3Iset32 v2.00.58-0601, (S3GSetup/IS10 2.00.58-0601)
      System: Win XP SP2  Build 2600 (Service Pack 2)
      Signature: 18-9968 (ANSI)
      Caller cmdline: ''
      SupportDir: 'C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\S3MF.tmp\'
    Called by custom setup app.
        AllowReboot: TRUE
             Prompt: TRUE
       SilentReboot: TRUE
             Prompt: FALSE
       RemoveWinINF: FALSE
       PreInstFiles: FALSE
       No UI Reboot: FALSE
        MenuAnimOff: FALSE
      MenuShadowOff: FALSE
    Find VendorID: 5333
      Driver INF at: D:\显卡驱动\uc06shr.inf
      Find hardware code: 0
      Custom uninstall info: C:\WINDOWS\UChromeP.uns
    HW found 0 - Ven:1106 Dev:3157 Ssven:0908 Ssdev:1975 Rev:03  at bus 1 dev 0 func 0  (InVga=1)

    ************** Begin Win2K/XP Driver Install **************
     Enum GUID {00000000-2ba8-0025-3c7f-1200fc169277} devs to match 'PCI\VEN_1106&DEV_3157&SUBSYS_19750908&REV_03':
      #0 Inst=00000800  'PCI\VEN_1106&DEV_0324&SUBSYS_00000000&REV_03\3&267A616A&0&00'
      #1 Inst=00000880  'PCI\VEN_1106&DEV_1324&SUBSYS_00000000&REV_00\3&267A616A&0&01'
      #2 Inst=00000900  'PCI\VEN_1106&DEV_2324&SUBSYS_00000000&REV_00\3&267A616A&0&02'
      #3 Inst=00000980  'PCI\VEN_1106&DEV_3038&SUBSYS_30381106&REV_90\3&267A616A&0&80'
      #4 Inst=00000A00  'PCI\VEN_1106&DEV_3038&SUBSYS_30381106&REV_90\3&267A616A&0&81'
      #5 Inst=00000A80  'PCI\VEN_1106&DEV_3038&SUBSYS_30381106&REV_90\3&267A616A&0&82'
      #6 Inst=00000B00  'PCI\VEN_1106&DEV_3065&SUBSYS_01071106&REV_8D\3&267A616A&0&50'
      #7 Inst=00000B80  'PCI\VEN_1106&DEV_3104&SUBSYS_31041106&REV_90\3&267A616A&0&84'
      #8 Inst=00000C00  'PCI\VEN_1106&DEV_3157&SUBSYS_19750908&REV_03\4&354AEA31&0&0008'
          Reg Location: PCI bus 1, device 0, function 0
        Match reg key (by PCI)!
      #9 Inst=00000C84  'PCI\VEN_1106&DEV_324B&SUBSYS_00000000&REV_00\3&267A616A&0&98'
      #10 Inst=00000D04  'PCI\VEN_1106&DEV_324E&SUBSYS_00000000&REV_00\3&267A616A&0&8F'
      #11 Inst=00000D84  'PCI\VEN_1106&DEV_3288&SUBSYS_32881106&REV_10\4&28D78340&0&0898'
      #12 Inst=00000E08  'PCI\VEN_1106&DEV_3324&SUBSYS_00000000&REV_00\3&267A616A&0&03'
      #13 Inst=00000E88  'PCI\VEN_1106&DEV_4324&SUBSYS_00000000&REV_00\3&267A616A&0&04'
      #14 Inst=00000F08  'PCI\VEN_1106&DEV_5324&SUBSYS_05811106&REV_00\3&267A616A&0&78'
      #15 Inst=00000F88  'PCI\VEN_1106&DEV_7324&SUBSYS_00000000&REV_00\3&267A616A&0&07'
      #16 Inst=00001008  'PCI\VEN_1106&DEV_8324&SUBSYS_00000000&REV_00\3&267A616A&0&88'
      #17 Inst=00001088  'PCI\VEN_1106&DEV_B198&SUBSYS_00000000&REV_00\3&267A616A&0&08'
        ->Found Inst=PCI\VEN_1106&DEV_3157&SUBSYS_19750908&REV_03\4&354AEA31&0&0008
     Parse INF file...
      Found Mfg line in INF: 'VIA.Mfg'.
       Ln 0: 'viagfx_3324,PCI\VEN_1106&DEV_3157' - Min match INF (by PCI)!
         Found keyname 'VIA/S3G UniChrome Pro II IGP ' - Match!
         Inf Driver date '06/14/2007', version '6.14.10.0368'
    Try to add 'PCI\VEN_1106&DEV_3157' to CompatibleIDs in 'SYSTEM\CurrentControlSet\Enum\PCI\VEN_1106&DEV_3157&SUBSYS_19750908&REV_03\4&354AEA31&0&0008'
      Succeeded.
    Do driver file copy logging.
    DoDriverFiles:  [viagfx_3324]  key='CopyFiles' fl=2
        Finished copy logging.
      Started timer.
    UpdateDriverForPnPDevice(PCI\VEN_1106&DEV_3157&SUBSYS_19750908&REV_03)
       and INF at 'D:\显卡驱动\uc06shr.inf'
      ...force install (PCI\VEN_1106&DEV_3157&SUBSYS_19750908&REV_03), error e0000101h.
        Failed to find last compatible ID: -4
      UpdateDriver failed, error e0000101h.
      StopTimer OK, but no timer action occurred.
    Trying to copy relevant part of Setupapi.log
      Copying 1320 bytes to C:\WINDOWS\s3setapi.log from C:\WINDOWS\setupapi.log
    -> Setup was unable to complete the installation.

    -> 安装程序无法完成安装。请查看 Windows 目录下的进度日志文件了解详细信息。 (-31)->C:\WINDOWS\s3iscfg.log
    ** Installation Failed **
    !! Setup was aborted !!
    ******** End of progress log ********

    2008年2月19日 3:57

答案

  • 确认你添加了一下组件:

    Display Control Panel

    Device Manager

    Windows Installer Service

    Class Installer - Display Adapters

    2008年2月19日 5:48
    版主

全部回复

  • 确认你添加了一下组件:

    Display Control Panel

    Device Manager

    Windows Installer Service

    Class Installer - Display Adapters

    2008年2月19日 5:48
    版主
  •  

    Class Installer - Display Adapters少了这个组件,不知道为什么之前都没有需要手动加过组件,这次没有自动加进去。加进去后,可以正确安装驱动了。谢谢了,雷哥!
    2008年2月19日 8:09
  •  

    2008年7月30日 13:07
  •  

    说不符合系统最地要求?这是为什么?求个喂达人教教我啦,急死了,游戏玩不起来!~~~~谢谢啦
    2008年7月30日 13:08
  • 呵呵,显然是你的显卡或者内存配置达不到游戏的要求,或者是没有添加OenpGL支持。可以尝试添加组件:OpenGL Support 试试

    2008年7月31日 6:29
    版主
  •  

    雷老大 我的则呢没找不到组建Class Installer - Display Adapters,只能找到Class Installer -Hardware compality。

    这事为什么啊 我把显卡驱动做成组建倒入,后进入xpe 可以调分辨率设置等 设备管理器下就是看不到已经安装的显卡,但是右下角可以看到显卡的托盘,也可以设置,设备管理器下还有一个未知设备,不知道是什么 ,应该怎么处理

    2008年8月5日 5:02
  • 找不到组建Class Installer - Display Adapters是由于该组件的可见性比较低,而你当前的组件可见度设置的比较高,所以在目标设计器中无法看到你设置可见度以下的组件,例如,组件的可见度为500,而你在目标设计器中设置的可见度为1000,那么1000以上的组件是可见的,而1000以下的组件不可见,即500的这个组件你看不到!
    解决方法:在目标设计器的Tools->options->Advanced中,更改Minmum的值为100,OK。

     

    另外你的显卡组件是否做的成功,要看你的分辨率和色彩是否能够正确的设置,如果可以,则说明你的显卡安装是成功的。设备管理器里的未知设备可能是别的设备没有正确的安装。你需要先确定这个问题。

     

    还有,按照论坛的规定,如果有新的问题,请开新的主题提问,好吗/

    2008年8月6日 3:10
    版主
  • 好的 谢谢雷老大 下次知道重新开新主题了

     

    2008年8月6日 3:36