none
显卡驱动组件 安装问题 RRS feed

  • 问题


  • 1、组件制作、导入一切正常,就是系统启动后显卡驱动没有装上(二楼有日志)
    2、安装驱动到最后一步说系统设置没有被改变
    3、添加硬件也不行
    4、打开注册表发现[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NVSvc] 项 ImagePath=system32\nvsvc32.exe,而我的原系统为 ImagePath=%SystemRoot%\system32\nvsvc32.exe,
    5、修改注册表后 添加硬件成功。重新安装成功。

    开发平台:win2003 ,xpesp2

    请帮忙分析一下注册表路径不对,是什么原因!
    分析了INF文件没发现问题,而且普通机器安装都没有问题。
    显卡驱动为   ftp://121.8.104.55:2121/vga/178.24_geforce_winxp_32bit_international_whql.exe


    • 已编辑 kk2008 2009年3月19日 4:51
    2009年3月19日 2:46

答案

全部回复


  • 安装日志

    (FBALOG.TXT)部分

     5:00:02 -  [FBAAddDevInstanceId] PCI\VEN_10DE&DEV_0393&SUBSYS_00000000&REV_A1\4&196AFE53&0&0008
     5:00:03 -  [PnpEnumThread: InstallDevice] SetupDiCallClassInstaller Error: 0x2, Device: NVIDIA GeForce 7300 GT 
     5:00:03 -  [FBAInstallNullDriver] PCI\VEN_10DE&DEV_0393&SUBSYS_00000000&REV_A1\4&196AFE53&0&0008

    (setupapi.log)部分

    [2009/03/18 05:00:02 276.387 Driver Install]
    #-019 正在查找硬件 ID(s): pci\ven_10de&dev_0393&subsys_00000000&rev_a1,pci\ven_10de&dev_0393&subsys_00000000,pci\ven_10de&dev_0393&rev_a1,pci\ven_10de&dev_0393,pci\ven_10de&dev_0393&cc_030000,pci\ven_10de&dev_0393&cc_0300
    #-018 正在查找兼容 ID(s): pci\ven_10de&cc_030000,pci\ven_10de&cc_0300,pci\ven_10de,pci\cc_030000,pci\cc_0300
    #-199 执行 "G:\WINDOWS\fba\fba.exe",用命令行: ..\fba\fba.exe
    #I022 在 "G:\WINDOWS\inf\oem45.inf" 中发现了 "PCI\VEN_10DE&DEV_0393";设备: "NVIDIA GeForce 7300 GT ";驱动程序: "NVIDIA GeForce 7300 GT ";提供程序: "NVIDIA";制造商: "NVIDIA";段: "nv4_G7x"
    #I023 实际安装部分: [nv4_G7x]。等级: 0x00000003。驱动程序有效日期: 10/07/2008。
    #-166 设备安装函数: DIF_SELECTBESTCOMPATDRV。
    #I063 从 [nv4_G7x] 中的 "g:\windows\inf\oem45.inf" 选择驱动器安装服务。
    #I320 设备的类别 GUID 依旧为: {4D36E968-E325-11CE-BFC1-08002BE10318}。
    #I060 设置所选的驱动器。
    #I058 选择最兼容的驱动器。
    #-124 正在做“仅复制”安装 "PCI\VEN_10DE&DEV_0393&SUBSYS_00000000&REV_A1\4&196AFE53&0&0008"。
    #-167 SPFILENOTIFY_NEEDMEDIA:  标志 = "", 描述= "NVIDIA Windows 2000/XP Driver Library Installation Disk 1", SourcePath = "g:\windows", SourceFile = "nvcpl.hlp", 表识 = 0x00000000。
    #W170 SPFILENOTIFY_NEEDMEDIA: 返回 FILEOP_SKIP。
    #-167 SPFILENOTIFY_NEEDMEDIA:  标志 = "", 描述= "NVIDIA Windows 2000/XP Driver Library Installation Disk 1", SourcePath = "g:\windows", SourceFile = "nvwcplen.hlp", 表识 = 0x00000000。
    #W170 SPFILENOTIFY_NEEDMEDIA: 返回 FILEOP_SKIP。
    #-166 设备安装函数: DIF_REGISTER_COINSTALLERS。
    #I056 注册了共同安装程序。
    #-166 设备安装函数: DIF_INSTALLINTERFACES。
    #-011 正在从 "g:\windows\inf\oem45.inf" 安装段 [nv4_G7x.Interfaces]。
    #I054 安装接口。
    #-166 设备安装函数: DIF_INSTALLDEVICE。
    #-035 正在处理服务添加/删除段 [nv4_G7x.Services]。
    #E281 添加服务: 修改现有 "NVSvc" 服务失败。 错误 2: 系统找不到指定的文件。
    #E033 错误 2: 系统找不到指定的文件。
    #E275 安装服务时出错。 错误 2: 系统找不到指定的文件。
    #E154 类别安装程式失败。 错误 2: 系统找不到指定的文件。
    #I060 设置所选的驱动器。
    #I125 为 "PCI\VEN_10DE&DEV_0393&SUBSYS_00000000&REV_A1\4&196AFE53&0&0008" 安装 NULL 驱动程序。
    #E122 设备安装失败。 错误 0xe0000219: 由于没有为设备范例指定函数驱动程序,安装没有成功。
    #I125 为 "PCI\VEN_10DE&DEV_0393&SUBSYS_00000000&REV_A1\4&196AFE53&0&0008" 安装 NULL 驱动程序。
    #I121 "PCI\VEN_10DE&DEV_0393&SUBSYS_00000000&REV_A1\4&196AFE53&0&0008" 的设备安装成功完成。

    2009年3月19日 2:47
  •  看你修改注册表搞定 说明你在制作驱动组件的时候把注册表设置搞错了
    建议重新对显卡驱动做组件 而且注意这次出错的键值!
    2009年3月19日 4:59
    版主
  • 驱动组件是按照这个做的 L版的 http://lzg-ad.blog.sohu.com/76094501.html 做的,制作和导入过程没有做过任何的手动修改注册表。
    感觉像是 对  inf 文件中 %11% 解析不对。


    另外网上好多制作显卡驱动遇到问题的人,看他们的日志都存在以下内容。

    #-035 正在处理服务添加/删除段 [nv4_G7x.Services]。
    #E281 添加服务: 修改现有 "NVSvc" 服务失败。 错误 2: 系统找不到指定的文件。
    #E033 错误 2: 系统找不到指定的文件。
    #E275 安装服务时出错。 错误 2: 系统找不到指定的文件。
    #E154 类别安装程式失败。 错误 2: 系统找不到指定的文件。
    #I060 设置所选的驱动器。
    2009年3月19日 6:03
  • 咋就没人告诉俺呢?
    2009年3月26日 2:57

  • 1、组件制作、导入一切正常,就是系统启动后显卡驱动没有装上(二楼有日志)
    2、安装驱动到最后一步说系统设置没有被改变
    3、添加硬件也不行
    4、打开注册表发现[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NVSvc] 项 ImagePath=system32\nvsvc32.exe,而我的原系统为 ImagePath=%SystemRoot%\system32\nvsvc32.exe,
    5、修改注册表后 添加硬件成功。重新安装成功。

    开发平台:win2003 ,xpesp2

    请帮忙分析一下注册表路径不对,是什么原因!
    分析了INF文件没发现问题,而且普通机器安装都没有问题。
    显卡驱动为   ftp://121.8.104.55:2121/vga/178.24_geforce_winxp_32bit_international_whql.exe



    2009年7月25日 3:28
  • 检查自己制作的组件,尤其是检查nvsvc32.exe的路径。正常是:%11%\nvsvc32.exe
    2009年7月25日 10:40
    版主