none
创建VM,配置管理员和密码失败 RRS feed

  • 问题

  • 我使用代码创建VM的时候,配置了管理员和密码,如图:

    但是似乎这样设置不成功,因为当我获取刚刚创建好的VM信息时,管理员和密码都为空。如图:

    2015年10月21日 8:48

答案

  • Hi,

    经过确认,这个不是SDK的问题, Azure java SDK也同样遇到类似的问题,这可能是service的问题,你可以尝试去Azure feedback论题提出这个问题:http://feedback.azure.com/forums/34192--general-feedback 

    Best Regards,

    Jambor

    如果您想进一步了解Windows Azure, Windows Azure 官网欢迎您的访问  


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2015年10月27日 1:27
    版主

全部回复

  • 您的用户名和密码是否符合复杂度要求,比如用户名不能使用Administrator; 密码必须含有大小写以及!@#$ 等字符并且长度超过八位。

    Would you know my name, if I saw you in heaven......

    2015年10月21日 9:38
    版主
  • Hi Michael Lee2:

    你看我的密码复杂度可够。

    2015年10月21日 9:48
  • Hi,

    从你获取的数据来看,你基本得到了一个空的实体,“HostName”也没有值,创建虚拟机需要一段时间,我建议你在Azure门户网站看到虚拟机是在running的状态下在测试,你也可以尝试在门户网站使用远程连接登录看看是否你设置的password是否有效。据我所知创建虚拟机用户密码是不可缺少的参数,如果你还是得不到相应的参数,请将提供更多详细信息方便我们还原问题。

    Best Regards,

    Jambor


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2015年10月22日 3:04
    版主
  • Hi Jambor yao:

    我确实是在VM运行状态下进行测试的,如图:

    但是获取的值,正如你所说的,基本是一个空实体。

    2015年10月22日 3:11
  • Hi,

    我想我还原了你的问题,我也同样没有得到AdminPassword,我将会和相关的团队联系,看看是否是一个By design的问题,同时我也在Azure SDK for Net Issue提出了这个问题:https://github.com/Azure/azure-sdk-for-net/issues/1517,也请留意最新状态, 如果有任何进展我将更新我的回复,这个过程需要一定的时间,对你造成的不便,深感抱歉。

    Best Regards,

    Jambor


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    2015年10月23日 5:37
    版主
  • Thanks Jambor,

    期待您的进一步回复

    2015年10月23日 7:33
  • Hi,

    经过确认,这个不是SDK的问题, Azure java SDK也同样遇到类似的问题,这可能是service的问题,你可以尝试去Azure feedback论题提出这个问题:http://feedback.azure.com/forums/34192--general-feedback 

    Best Regards,

    Jambor

    如果您想进一步了解Windows Azure, Windows Azure 官网欢迎您的访问  


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    2015年10月27日 1:27
    版主