none
关于ce6的device emulator和activesync通讯的问题 RRS feed

  • 问题

  • 我在vs2005中安装了wince 6.0 R2版本,新建了模拟器的项目。build之后,device emulator能正常启动也并没有报错,CE模拟器也能连上公司的局域网。但active sync一直连不上。

     

    在设备仿真管理器里cradle后,active sync会开始自动搜索,但过一会儿就显示是个无法识别的设备  请问这是怎么回事啊?  google了也没找到很好的办法,在这里请求大家指点迷津

    2008年7月7日 6:31

答案

  •  

    It can connect to Activesync successfully

     

    我的做法是 disable KITL,and run command dmacnect.exe on device side, cradle...  OK

     

    thanks all

    2008年7月10日 3:51

全部回复

  •  

    我的activesync是4.5,虚拟网卡和vs_emulator都安装上了  其它的都挺正常的,就是active sync无法连接上    是不是哪儿出了问题?
    2008年7月7日 6:54
  • 确保ActiveSync里面允许了DMA方式连接设备。

    2008年7月8日 5:28
    版主
  • 还是不行,我已经在ActiveSync里允许了DMA方式连接设备。 但事实上,还是连不通。错误信息为无法识别此设备。

     

    有个细节,我每次都是在VS中用Attach Device的方式启动Emulator的,这是不是会对Active Sync有影响? 

     

    我的VS、Active Sync为中文版,而Wince 6.0 R2和Microsoft Device Emulator 、Virtual Machine Network Driver for Microsoft Device Emulator都为英文版  请问这会不会影响Active Sync?

    2008年7月9日 9:26
  •  

    For CE6, it's normal behavior that Device Emulator cannot sync with activesync4.5

    Please set IMGNOKITL=1 and it's better to set WINCEDEBUG=retail.

     

    This issue has nothing to do with localization. "Attach Device" is the right way to launch emlator.

    2008年7月9日 15:40
  •  

    It can connect to Activesync successfully

     

    我的做法是 disable KITL,and run command dmacnect.exe on device side, cradle...  OK

     

    thanks all

    2008年7月10日 3:51
  • 您好.小弟目前也遇到同樣問題

    可以請教關於比較詳細的說明嗎?

    另外請問 dmacnect.exe 是什麼呢?

     

    感激

    2008年10月22日 14:15
  •  

    呵呵,就是DMA connect  我猜的,未必正确
    2008年10月27日 15:01