none
命令行安装sql server 2008 express R2怎么开启远程连接? RRS feed

  • 问题

  • 是这样的,要从命令行安装sql server 2008 express R2,下面是我的批处理,已经可以安装了,但碰到2个问题

    start /wait %CD%/SqlExpress2008/SQLEXPRWT_x86_ENU.exe /QS /IACCEPTSQLSERVERLICENSETERMS /ISSVCACCOUNT=NT AUTHORITY\SYSTEM /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM"  /IAcceptSQLServerLicenseTerms /ACTION=Install /INSTANCENAME=GUSQLEXPRESS /TCPENABLED=1 /SECURITYMODE=SQL /SAPWD="root123456"/BROWSERSVCSTARTUPTYPE=Automatic  

    1.可以启用tcp/ip了,但问题是sql server 指定的是一个动态端口,而我的程序用1433,这是不是跟没有正确开启远程连接有关系,(好像我的程序不写也行,但要保证sql server 开了1433端口)我的程序连接url   jdbc.url=jdbc:sqlserver://localhost:1433; DatabaseName=administratorddbb

    2. 我写的sa的密码,为什么不正确? 

    怎么能通过命令行或批处理加上开启远程这个参数?

    2011年12月6日 3:33

答案

  • 你好,

    根据你提供的命令,你安装的命名实例,不是默认实例。命名实例默认情况下是动态分配端口的,所以在你的连接字符串中指定1433端口是不合适的。 这种情况下,你可以不指定端口,而直接指定实例名称,如:

    jdbc:sqlserver://localhost;instanceName= GUSQLEXPRESS; databaseName= administratorddbb;<更多配置信息> 详细信息,请参考: http://msdn.microsoft.com/zh-cn/library/ms378428.aspx

    同时,你需要在安装的时候启用SQL Server Browser:/BROWSERSVCSTARTUPTYPE=Automatic。详细信息,请参考:http://msdn.microsoft.com/zh-cn/library/ms144259.aspx

    至于SA用户的密码问题,请检查输入是否正确,或者是否有人在安装完成后进行了更改。


    Stephanie Lv

    TechNet Community Support




    2011年12月8日 2:19

全部回复

  • 1. 使用Configuration Manager檢查TCP/IP是否啟用,若要調整SQL Server Port Number,也可以在Configuration Manager中變更。

    2. 使用SSMS檢查看看sa的帳號是否啟用。


    以上說明若有錯誤請指教,謝謝。
    http://www.dotblogs.com.tw/terrychuang/
    2011年12月6日 4:03
  • 1. 使用Configuration Manager檢查TCP/IP是否啟用,若要調整SQL Server Port Number,也可以在Configuration Manager中變更。

    2. 使用SSMS檢查看看sa的帳號是否啟用。


    以上說明若有錯誤請指教,謝謝。
    http://www.dotblogs.com.tw/terrychuang/
    2011年12月6日 4:03
  • 1. Should replace localhost with server name in jdbc string because you can't connect to sql remotely with localhost. You can enable tcp/ip, named pipes, change sql port number in sql server configuration manager as Terry said above. Or by modifying registry keys.

    2. You can logon sql as any sysadmin user with ssms and change sa password there.

    2011年12月6日 13:59
  • 各位大牛们,我已经成功通过注册表来开启了1433端口,看了下tcp/ip也是启用的,现在发现问题是不知道为什么sa的账户密码不对可是我指定了在批处理中

    这里

    /SAPWD="root123456"

    另外,因为我是给客户做一键安装,也就是说安装完成后不能在去让客户手动操作进入ssms什么的,所以安装完后在去操作是不行的啊

    2011年12月7日 1:28
  • 你好,

    根据你提供的命令,你安装的命名实例,不是默认实例。命名实例默认情况下是动态分配端口的,所以在你的连接字符串中指定1433端口是不合适的。 这种情况下,你可以不指定端口,而直接指定实例名称,如:

    jdbc:sqlserver://localhost;instanceName= GUSQLEXPRESS; databaseName= administratorddbb;<更多配置信息> 详细信息,请参考: http://msdn.microsoft.com/zh-cn/library/ms378428.aspx

    同时,你需要在安装的时候启用SQL Server Browser:/BROWSERSVCSTARTUPTYPE=Automatic。详细信息,请参考:http://msdn.microsoft.com/zh-cn/library/ms144259.aspx

    至于SA用户的密码问题,请检查输入是否正确,或者是否有人在安装完成后进行了更改。


    Stephanie Lv

    TechNet Community Support




    2011年12月8日 2:19
  • 各位大牛们,我已经成功通过注册表来开启了1433端口,看了下tcp/ip也是启用的,现在发现问题是不知道为什么sa的账户密码不对可是我指定了在批处理中

    这里

    /SAPWD="root123456"

    另外,因为我是给客户做一键安装,也就是说安装完成后不能在去让客户手动操作进入ssms什么的,所以安装完后在去操作是不行的啊

    Is mixed authentication enabled? You have to try and fix issues to make it working in your way.

    2011年12月8日 3:39