none
已在此计算机上安装相同或更高版本的 .NET Framework 4

    问题

  • 我的电脑上使用的是VS Community2015,安装的时候就装了4.6的几个版本的.net,但是因为最近要使用MATLAB和C混合编程,按照网上的说法,需要用到MINGW和Microsoft Windows SDK 7.1(C/C++) and .NET Framework 4 (ISO)(地址,但是官网上找到的最新的Microsoft Windows SDK 7.1(C/C++)带的是.net 4,安装的时候时候装不上,并且有下载了.net独立的安装包,但是提示已经有了“已在此计算机上安装相同或更高版本的 .NET Framework 4”,

    所以我应该怎么才能安装上.net 4,或者还是有其他的办法完成SDK的安装?

    谢谢


    2016年12月27日 5:15

答案

  • .NET 版本是向下兼容的,4.6的版本是可以兼容4.0的。

    你不需要安装4.0版本。


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2016年12月28日 4:39
    版主

全部回复

  • Hi WLY_WINDOWS,

    windows 7 是自带.NET 4的,应该是不需要在另行安装。

    你可以打开windows 7电脑设置,查看一下.net 有没有被安装成功。如果安装了,你可以直接使用。

    Best Regards,

    Hart


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2016年12月27日 9:38
    版主
  • 你好,我在“程序与功能”中并没有找到.net 4,而只有.net 4.6和4.6.1,但是MATALB程序要求是要安装.net4,但是好像并不能再安装4

    2016年12月28日 4:34
  • .NET 版本是向下兼容的,4.6的版本是可以兼容4.0的。

    你不需要安装4.0版本。


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2016年12月28日 4:39
    版主