locked
Windows CE里,只能安装.NET Compact Framework吗? RRS feed

  • 问题

  • Windows CE里,只能安装.NET Compact Framework吗?能不能直接安装.NET Framework 2.0?

    我看现在好多手机屏幕分辨率已经达到1024*768了。应该可以吧。
    I am using Windows Server 2003, CentOS Linux 5.2, Windows XP, VirtualBox 3.0.4, Visual Studio 2005, Eclipse 3.5, NOtepad++ 5.4.5, Microsoft.NET Framework 2.0 SP2, C# 2.0, IIS 6.0, Apache 1.3.41, Nginx-0.7.61, SQL Server 2000, MySQL 5.0, FireBird 2.1.2, PHP 5.2.10, OpenOffice 3.1 and EIOffice2009 SP1.
    2009年9月1日 14:16

答案

  • 只能用.NET CF.
    貌似还可以用.NET MF,这个就不是很清楚了.

    现在.NET CF 3.5的功能还可以吧,至少比2.0强很多了,我们在2.0下面写程序,够呛....
    • 已标记为答案 dvdvip 2009年9月2日 10:44
    2009年9月2日 2:23
  • 只能安装compact framework, 不能安装.net framework.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • 已标记为答案 dvdvip 2009年9月2日 10:44
    2009年9月2日 6:11
  • 可能跟处理器架构也有关系吧。
    现在很多手机都采用的ARM,x86的很少。
    以前试过EBox(x86的)上跑XPE。
    .NET Compact Framework是.NET Framework的子集,有许多在 .NET Framework 可以运行的代码在 .NET Compact Framework 上会无法运行,例如 System.Net.WebClient 类在 .NET Compact Framework 中就没有,开发人员必须使用 HttpWebRequest 和 HttpWebResponse 类来改写原先由 WebClient 所提供的功能。
    可以参考wiki上的介绍,http://en.wikipedia.org/wiki/.NET_Compact_Framework
    施炯
    • 已标记为答案 dvdvip 2009年9月4日 4:09
    2009年9月3日 3:08
  • 主要还是功耗的问题,呵呵。
    期待更加高性能、低功耗的芯片。
    摩尔定律体现。
    施炯
    • 已标记为答案 dvdvip 2009年9月4日 22:08
    2009年9月4日 4:16

全部回复

  • 只能用.NET CF.
    貌似还可以用.NET MF,这个就不是很清楚了.

    现在.NET CF 3.5的功能还可以吧,至少比2.0强很多了,我们在2.0下面写程序,够呛....
    • 已标记为答案 dvdvip 2009年9月2日 10:44
    2009年9月2日 2:23
  • 只能安装compact framework, 不能安装.net framework.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • 已标记为答案 dvdvip 2009年9月2日 10:44
    2009年9月2日 6:11
  • 为什么手机不能直接安装Windows XP,只能安装Windows CE? 如果能装PC操作系统,不是能安装.NET Framework 2.0了吗?现在手机功能已经很强大了吧?

    compact framework是不是少了很多功能?
    I am using Windows Server 2003, CentOS Linux 5.2, Windows XP, VirtualBox 3.0.4, Visual Studio 2005, Eclipse 3.5, NOtepad++ 5.4.5, Microsoft.NET Framework 2.0 SP2, C# 2.0, IIS 6.0, Apache 1.3.41, Nginx-0.7.61, SQL Server 2000, MySQL 5.0, FireBird 2.1.2, PHP 5.2.10, OpenOffice 3.1 and EIOffice2009 SP1.
    2009年9月2日 10:46
  • 可能跟处理器架构也有关系吧。
    现在很多手机都采用的ARM,x86的很少。
    以前试过EBox(x86的)上跑XPE。
    .NET Compact Framework是.NET Framework的子集,有许多在 .NET Framework 可以运行的代码在 .NET Compact Framework 上会无法运行,例如 System.Net.WebClient 类在 .NET Compact Framework 中就没有,开发人员必须使用 HttpWebRequest 和 HttpWebResponse 类来改写原先由 WebClient 所提供的功能。
    可以参考wiki上的介绍,http://en.wikipedia.org/wiki/.NET_Compact_Framework
    施炯
    • 已标记为答案 dvdvip 2009年9月4日 4:09
    2009年9月3日 3:08
  • 手机不用x86,却用ARM。真麻烦。
    I am using Windows Server 2003, CentOS Linux 5.2, Windows XP, VirtualBox 3.0.4, Visual Studio 2005, Eclipse 3.5, NOtepad++ 5.4.5, Microsoft.NET Framework 2.0 SP2, C# 2.0, IIS 6.0, Apache 1.3.41, Nginx-0.7.61, SQL Server 2000, MySQL 5.0, FireBird 2.1.2, PHP 5.2.10, OpenOffice 3.1 and EIOffice2009 SP1.
    2009年9月4日 4:13
  • 主要还是功耗的问题,呵呵。
    期待更加高性能、低功耗的芯片。
    摩尔定律体现。
    施炯
    • 已标记为答案 dvdvip 2009年9月4日 22:08
    2009年9月4日 4:16