none
.Net FrameWork 4.0 的向下兼容性 怎么样? RRS feed

  • 问题

  • .Net FrameWork 4.0 能不能兼容 作为 2.0 开发的应用程序的 平台? 我发现 SQL Server 2005 运行于 但 4.0的环境下 报错 无法运行, vs C# 2005 Express 也建不了项目
    2010年12月27日 8:53

答案

  • 你好

    .Net Framework 4.0 和 2.0/3.0/3.5 是两种不同版本的framework。 他们两者的Gc也不相同。所以2.0的程序在4.0上是不能运行的。因此你至少少得装2.0/3.0/3.5其中一个。


    Cookie Luo[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • 已标记为答案 Cookie Luo 2011年1月3日 2:34
    2010年12月28日 6:33
  • dear
    1.小的跟Stone一样看不懂你在问啥。
    2..Net 4.0某些元件是与其他版本不同的,所以你的计算机若有用到4.0没支援的方法,会出错

    [.NET Framework 4 中的过时成员]
    http://msdn.microsoft.com/zh-cn/library/ee471421.aspx
    秘訣無它,唯勤而已 http://www.dotblogs.com.tw/yc421206/
    • 已标记为答案 Cookie Luo 2011年1月3日 2:35
    2010年12月29日 1:05

全部回复

  • sql server 2005单独安装的时候 会自动安装.NET FW 2.0

    VS也一样。安装成功应该都可以运行的。

    什么叫无法运行?具体错误是什么?


    family as water
    2010年12月28日 0:54
  • 你好

    .Net Framework 4.0 和 2.0/3.0/3.5 是两种不同版本的framework。 他们两者的Gc也不相同。所以2.0的程序在4.0上是不能运行的。因此你至少少得装2.0/3.0/3.5其中一个。


    Cookie Luo[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • 已标记为答案 Cookie Luo 2011年1月3日 2:34
    2010年12月28日 6:33
  • dear
    1.小的跟Stone一样看不懂你在问啥。
    2..Net 4.0某些元件是与其他版本不同的,所以你的计算机若有用到4.0没支援的方法,会出错

    [.NET Framework 4 中的过时成员]
    http://msdn.microsoft.com/zh-cn/library/ee471421.aspx
    秘訣無它,唯勤而已 http://www.dotblogs.com.tw/yc421206/
    • 已标记为答案 Cookie Luo 2011年1月3日 2:35
    2010年12月29日 1:05