none
VS2010 按 F11进行调试时就崩溃,如图 RRS feed

答案

  • Hi Tim,

    如果你仅仅是创建一个很简单的程序然后进行调试,你还能遇到相同的问题么?如果还能得到相同的问题,我想很可能是你的VS出现了问题。请你在命令行运行以下命令看看能否帮助你解决问题:

    Devenv.exe /SafeMode: 以安全模式打开VS2010。

    Devenv.exe /ResetSettings: 将VS IDE 重置成默认设置。

    Devenv.exe /ResetAddin: 去除VS 中的一些Add-ins。

    Devenv.exe /ResetSkipPkgs: 去掉VS中的VSPackages。


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    2012年3月26日 4:53
    版主
  • Devenv  /SafeMode 下是可以调试的。。其他模式下都不行。。VS已经重新安装多次了。。安装包也重新下载了
    2012年3月28日 6:18

全部回复

  • Hi Tim,

    如果你仅仅是创建一个很简单的程序然后进行调试,你还能遇到相同的问题么?如果还能得到相同的问题,我想很可能是你的VS出现了问题。请你在命令行运行以下命令看看能否帮助你解决问题:

    Devenv.exe /SafeMode: 以安全模式打开VS2010。

    Devenv.exe /ResetSettings: 将VS IDE 重置成默认设置。

    Devenv.exe /ResetAddin: 去除VS 中的一些Add-ins。

    Devenv.exe /ResetSkipPkgs: 去掉VS中的VSPackages。


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    2012年3月26日 4:53
    版主
  • Devenv  /SafeMode 下是可以调试的。。其他模式下都不行。。VS已经重新安装多次了。。安装包也重新下载了
    2012年3月28日 6:18
  • 其他工程会不会出现这种情况,有时候工程代码的问题也会引起 VS2010崩溃,我目前也遇到了这种情况,在添加新页面或修改保持或生成 都会崩溃,但我其他项目 vs2010 就不会出现这情况,很郁闷。

     

    2012年3月28日 8:02
  • 看的不懂   用命令行动直接就启动软件了

    2012年4月11日 3:07
  • Hi Tim,

    我也遇到了相同的问题,我尝试过重新安装,安装完以后也还是不能进行单步调试,除了F5可以使用,F10,F11均不能使用,之后我对设置进行了重置,但是也不起作用。只能在安全模式下进行调试。

    这样也解决不了问题,但是我知道是因为某个项目导致了VS2010调试的崩溃。于是我将该项目从workspace中移除,再对VS2010进行了重置,问题解决了!

    ChenCheng

    2012年4月20日 1:43
  • Devenv  /SafeMode 下是可以调试的。。其他模式下都不行。。VS已经重新安装多次了。。安装包也重新下载了

    遇到了同样的问题。 Win7系统,前两天都是好好的。今天突然就不能调试了。  新建项目时也会自动关闭VS并重启。

    只有  safemode 模式下 可以调试。

    VS重装、修复过N多次了。 问题依然存在。。。。

    2014年3月12日 17:54