none
关于<meta>标签的错误 RRS feed

  • 问题

  • 如题:

    我的程序在本机测试成功 , 放到服务器上显示如下错误(The 'meta' start tag on line 9 position 3 does not match the end tag of 'head'. Line 48, position 3),检查好几遍是在找不到错误 , 故在此求救于各位大神 , 谢谢了...

    开发环境 : Windows Server 2008 R2 , IE9 , IIS7.5

    服务器环境 :Windows Server 2003 , IE8 , IIS6

    .前台代码如下:

    <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Reflash.aspx.cs" Inherits="Pac2Pay.WebSite.Reflash" %>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=gb2312" />
        <meta http-equiv="refresh" content="1800" />
        <title>Reflash</title>
        <style type="text/css">
            #container
            {
                width: 300px;
                height: auto;
                line-height: 22px;
                text-align: center;
                overflow: hidden;
                ;
                top: 50%;
                left: 50%;
                margin-top: -40px;
                margin-left: -150px;
            }
        </style>
    </head>
    <body>
        <div id="container">
            <img alt="loading..." src="resource/Img/loading11.gif" width="220" height="19" />
            <br />
            <br />
            正在处理数据,请勿关闭页面...
        </div>
    </body>
    </html>



    • 已编辑 HeiSeYouMoo 2013年4月25日 7:31 添加IIS信息
    2013年4月25日 3:23

答案

全部回复

  • 经过本地测试,未发现问题。

    请将错误页面截图发一下!


    e-mail:ist_te@hotmail.com


    2013年4月25日 5:09
  • 改成這樣試試

        <meta http-equiv="Content-Type" content="text/html; charset=gb2312"></meta>
        <meta http-equiv="refresh" content="1800"></meta>



    Best regards

    2013年4月25日 5:18
  • 改成這樣試試

        <meta http-equiv="Content-Type" content="text/html; charset=gb2312"></meta>
        <meta http-equiv="refresh" content="1800"></meta>



    Best regards

    这个试过了,不行 !

    会不会和操作系统有关系呢 ?


    2013年4月25日 5:43
  • 经过本地测试,未发现问题。

    请将错误页面截图发一下!


    e-mail:ist_te@hotmail.com


    邮件已发送 , 在此表示感谢 ... ^_^ ...
    2013年4月25日 5:50
  • 经过本地测试,未发现问题。

    请将错误页面截图发一下!


    e-mail:ist_te@hotmail.com


    邮件已发送 , 在此表示感谢 ... ^_^ ...
    您的邮寄已经收到,请问此页面在后台有所操作么。比如:RSS、XML

    e-mail:ist_te@hotmail.com

    2013年4月25日 8:23
  • 请检查XML是否有问题!

    e-mail:ist_te@hotmail.com

    2013年4月25日 9:10
  • 经过本地测试,未发现问题。

    请将错误页面截图发一下!


    e-mail:ist_te@hotmail.com


    邮件已发送 , 在此表示感谢 ... ^_^ ...

    您的邮寄已经收到,请问此页面在后台有所操作么。比如:RSS、XML

    e-mail:ist_te@hotmail.com

    我刚刚新建了个测试页面1.aspx , 没有后台代码 , 前台代码和之前的refresh页 相同, 也提示这个错误 !!! 应该和后台没关系 !

    我再次创建了1个静态页面1.html , 代码和之前的refresh页 相同 , 也面就正常运行了 ... 


    2013年4月25日 9:13
  • 我将您的代码也是放入aspx页面测试的,可以正常访问呢!

    e-mail:ist_te@hotmail.com

    2013年4月25日 9:32