none
s2017 debug的问题 RRS feed

  • 问题

  • vs2017使用时遇到一个问题

    在debug时  如果修改了代码再继续调试 就会引发异常System.ExecutionEngineException 停止了,要怎么解?

    之前一直使用vs2010,就没有这个问题,很郁闷

    2017年11月23日 8:40

全部回复

  • 请取消一下两个选项再试试:

    目前也有其他遇到类似的问题,取消以上两个选项可以作为一个暂时的解决方案。

    谢谢理解和支持。

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    2017年11月24日 7:46
  • 你好,

    请问下您的问题得到解决了吗?

    如果Fletch的答案对您有帮助,可以点击“标记为答复”,这样其他社区成员也会更加容易搜索到这个帖子。

    感谢您的理解与配合:)


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年11月27日 1:35
    版主
  • 我现在出现了新的问题,快要被vs2017搞崩溃了

    在您给我回复之前,我把vs2017卸载重装了,现在的问题更诡异了,之前的项目用2017打开可以编译、运行,但是现在用2017打开后,只要是类文件里引用了我自已项目的命名空间,都编译报错了,但是当我打开这个文件,这个编译错误又被vs删除了,我需要一个一个文件的打开,才能去掉所有的编译错误:(

    2017年11月27日 2:22
  • 刚装了vs2015, 竟然也有这个问题, 按照您的方法试了下,问题依然存在
    2017年11月27日 6:22
  • 你好,

    从您的描述来看,如果卸载重装仍然有问题,根本原因可能和系统环境有关。

    请检测您的系统更新,安装好最新的更新和补丁, 然后用sfc/scannow去修复一下系统文件,重启电脑,运行VS,看是否一切正常。


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年11月27日 9:30
    版主