none
关于InitializeError error #2104的问题(急!) RRS feed

  • 常规讨论

  • 大家帮帮忙啊,我在一个aspx网页里加入了一个MediaPlayer然后正常配置,有些情况下网页显示正常,有些时候就会出现错误:

    行: 454

    Char: 17

    错误: Sys.InvalidOperationException: InitializeError error #2104 in control 'MediaPlayer1' : 无法下载Silverlight应用程序。请查看Web服务器设置

    代码:0

    URL: .......

     

    我的环境是Visual Studio 2008 SP1,Windows Vista,IIS 7,Silverlight 2 RTW...

    大家帮帮忙吧,修改IIS里的MIME也没效果.....

    • 已更改类型 天使坠Moderator 2011年7月12日 2:53 这个安装问题,以后最好是整理一下
    2008年11月10日 13:45

全部回复

  • MIME 类型
    .xaml application/xaml+xml
    .xap application/x-silverlight-app

     

    如果有些机器可以有些机器不可以,我觉得主要还是你有些机器IE的配置问题,不如安全里面的Xaml Active 下载等选项

     

    如果你是一台机器,打开页面可以,刷新不可以,反复刷新时而可以时而不可以,这个就应该是你的程序或者网络的问题了

    2008年11月10日 15:02
    版主
  • 你说的 修改IIS里的MIME也没效果 是指改动了你IIS的配置如果有机器上显示是正确的就证明你的IIS没有配置错误,看提示是 AJAX无法下载的错误,建意看一看网络通道是否有问题,MediaPlayer是不是指向了错误的影像地址,是不是有大量的AJAX并发到服务器影响了下载,IIS服务器端是否做了并发限制,Vista(由于不是服务器的版本)的IIS是有并发限制的。

    http://www.microsoft.com/downloads/details.aspx?FamilyID=48364A72-D54E-46DC-AACF-E3BE887D17A6&displaylang=en

     

    这个东东在XP下可以修改IIS的并发,但在VISTA下我没做过测试,你可以用用看。

    2008年11月10日 23:08
  • 并不是IE配置的问题,是同一台机器,新建网站,添加MediaPlayer,配置都一样,但有时就可以正常播放,有时就会出现这个问题。。。

     

    我的初步判断可能是VS里的某些配置的问题,但找不到具体的不同之处。。。

    2008年11月14日 3:42
  •  申延超 写:

    你说的 修改IIS里的MIME也没效果 是指改动了你IIS的配置如果有机器上显示是正确的就证明你的IIS没有配置错误,看提示是 AJAX无法下载的错误,建意看一看网络通道是否有问题,MediaPlayer是不是指向了错误的影像地址,是不是有大量的AJAX并发到服务器影响了下载,IIS服务器端是否做了并发限制,Vista(由于不是服务器的版本)的IIS是有并发限制的。

    http://www.microsoft.com/downloads/details.aspx?FamilyID=48364A72-D54E-46DC-AACF-E3BE887D17A6&displaylang=en

     

    这个东东在XP下可以修改IIS的并发,但在VISTA下我没做过测试,你可以用用看。

     

    这个东东下了,正在试。。。

    MediaPlayer的影像地址没有问题,因为有两个网站的配置的视频地址是完全相同的,但其中一个就有问题另一个正常。。。

     

    如果是配置问题的话,有哪些配置可以影响到AJAX的下载问题呢?(好像只说是Silverlight无法下载,有AJAX的话也是可以下载的)

    2008年11月14日 3:48
  • 建议还是装个虚机在win03 server下试试,毕竟现在不管使用率还是稳定性03还是最多的

    2008年11月14日 7:24
    版主
  • 这个问题时间太长,2008年的,我就做为讨论贴吧!
    努力!完成了js解析器,还差一个svg插件,一个绘图程序,做好自己,呵呵~!
    2011年7月12日 2:53
    版主