none
VS2010可以同时开发Silverlight 3和4吗? RRS feed

  • 问题

  • 在进行Silverlight 3项目开发,现在用VS2008+Silverlight tool 3,Silverlight插件一升级,VS就说“未安装Silverlight托管调试包”

    Windows Update天天提醒升级Silverlight 4,访问一些网站也开始要求Silverlight 4,快崩溃了……

    如果改成VS2010,Silverlight 3、4的开发环境能否并存?或者,能否单纯解决上述问题?

    2010年6月9日 7:11

答案

  • VS2010中,SL开发环境是可以并存的。在新建Silverlight解决方案时可以选择版本
    共同努力,共同提高
    kaedei#live.cn My BLOG
    • 已标记为答案 Aegaina 2010年6月12日 0:37
    2010年6月10日 14:53

全部回复

  • 你好!

         Silverlight不支持并行安装,但是新版本的Silverlight 会完全的兼容以前的版本,现有的应用程序基本保持不变。所以你升级成Silverlight 4,开发工具也更新一下就可以了!


    周雪峰
    • 已标记为答案 Aegaina 2010年6月10日 6:39
    • 取消答案标记 Aegaina 2010年6月10日 15:41
    2010年6月9日 10:33
    版主
  • “开发工具更新”?是指开发工具都升级到4吗?可是公司规定,不允许用Silverlight 4开发……
    2010年6月9日 11:24
  • 你好!    如果公司有规定,那你先不用升级!

        Windows Update的通知是可以自己设置的!


    周雪峰
    2010年6月9日 12:32
    版主
  • 那么开发Silverlight 3的机子就无法打开Silverlight 4程序,自己不开发看别人的都不行,这感觉很荒谬……

    2010年6月9日 12:42
  • VS2010中,SL开发环境是可以并存的。在新建Silverlight解决方案时可以选择版本
    共同努力,共同提高
    kaedei#live.cn My BLOG
    • 已标记为答案 Aegaina 2010年6月12日 0:37
    2010年6月10日 14:53
  • 并存的时候各个版本都可以正常调试吗?
    2010年6月10日 15:42