none
Xaml编辑器 语法提示,不知道显示的是什么语言 RRS feed

  • 问题

  • 如图所示,安装VS2017 最新版15.5.0,之前的版本也存在这个问题,看着像是日文?棒子文??

    我电脑系统语言就只有中文和英文

    vs版本是中文版


    2017年12月7日 6:17

全部回复

  • Hi,

    欢迎在MSDN论坛发帖。

    因为你的问题涉及VS的安装问题,我将把帖子移到VS讨论论坛。

    Best Regards,

    Hart


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年12月8日 7:08
  • 你好,

    请问下您是在哪儿下载的VS呢?

    刚刚VS发布了最新的版本15.5.1, 请尝试再次登陆微软官网:https://www.visualstudio.com/downloads/ 下载最新的installer,或者直接更新到最新版本,并且运行安装VS installer,修复一下VS。

    同时检测并且更新Windows 系统更新,将所有的补丁打上,重启电脑,重新运行VS,看是否一切正常。


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    2017年12月8日 8:01
    版主
  • 在官网下载的vs-installer,然后在线安装的。16299系统发布后没几天,我重装的系统,在线安装重装的vs2017,之后vs每更新一次,我都更新的

    今天更新了15.5.1,遇到问题的时候还是提示那样的乱码,我复制出来,

    ₩ワᆰ│テᄑ₩ノᄒ¥ネᄚ¥ᄆ゙₩タᄃ¬タワ¬タン タツ 

    谷歌翻译出来,什么都不是。。。。。。

    很诡异的问题

    这个问题一直存在,更新vs也没用

    2017年12月8日 8:06
  • 你好,

    根据您的描述来看,这个问题的原因更加偏向于系统环境。我之前遇到过一个帖子,一个日本人,他在日语系统上运行英文版本的VS也一直输出乱码。

    据我了解,Win10 Fall Creators Update这一系统有一些bug,包括开发UWP应用程序。在系统与VS 兼容性之间存在问题。你可以试试在safemode下运行VS, 去排除一些三方插件的影响。


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年12月8日 9:36
    版主
  • 安全模式下面启动vs,提示未知硬件错误。。。

    看来这个问题是解决不了了😭😭😭

    2017年12月9日 7:50
  • 你好,

    我已经将这个问题通过 Report a Problem 提交上去了,请看链接:

    https://developercommunity.visualstudio.com/content/problem/164834/vs2017-xaml%E7%BC%96%E8%BE%91%E5%99%A8%E5%87%BA%E7%8E%B0%E4%B9%B1%E7%A0%81.html

    Visual Studio产品组的人会关注并且解决这个问题,请耐心等待,如果有更新,我会继续通知您。
    感谢您的理解与配合:)


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年12月11日 3:08
    版主
  • 谢谢,不过我看他们不会注意的。

    之前我也提交过bug,都没有下文。。。。

    2017年12月11日 4:28
  • 你好,

    确实存在这种情况,一般我们的客户遇到IDE使用问题,或者我们自己测出了问题都会report给产品组那边, 有的时候也和系统版本有关的,Win10 Fall Creators Update也会存在一些bug。产品组修改完善这些可能还需要一段时间,目前也确实给您带来不便了。 如果真的耽误您开发项目的话可以考虑一下把Visual Studio语言换成英文的吗? 或者先将就使用以下Visual Studio 2015.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    2017年12月11日 9:34
    版主
  • 谢谢,不用了

    反正我现在也习惯了,开发uwp好像必须要用最新的vs,哈哈

    2017年12月11日 10:12
  • 这个东西影响使用吗?如果运行起来没什么问题的话可以不用关注。Xaml desiger 奇怪的问题很多,以前还提示我找不到自己定义的类,但是运行起来就没有问题。 
    2017年12月13日 6:08
  • 还好,不影响编译,哈哈
    2017年12月13日 6:10
  • 哈哈哈,那这个就无所谓了。
    2017年12月13日 6:16