none
在安装好的xpe 下使用vc6.0 编译出错:error spawning ' vcspawn.exe' ,怎么办? RRS feed

  • 问题

  • 错误信息:
     can not start tool
    error spawning ' vcspawn.exe'   build could not perform.
    需要添加什么组件?
    另外:
    有没有不重新编译XPE IMAGE 的方法解决这个问题?
    XP Embedded 开发
    2010年1月6日 5:45

答案

  • .net framework

    另外你系统是在D盘么?

    建议你用filemon监视一下


    肖正波
    诚亚博瑞科技有限公司
    我的WIndows Embedded中文技术BLOG:
    www.XPE.cc
    http://m--y.spaces.live.com/blog/
    QQ:1320232327(另外两个已满)
    MSN:questor_87@hotmail.com
    MCTS:70-571;MCTS:70-577;MCTS:70-582
    Microsoft MVP(2010)
    2010年6月25日 16:14
    版主

全部回复

  • 怎么没有人回答啊,着急.因为开发工具前段时间卸掉了,今天重新安装工具,使用以前的.slx文件,发现很多组件找不到,可能需要重新安装系统才行,所以希望找个能在作好的系统下就直接能解决这个问题的办法.不知道哪位高手知道?


    XP Embedded 开发
    2010年1月6日 7:45
  • 首先Visual C++ Runtime 相关的几个组件要添加。

    如果还出现这个问题。用Depends查看exe需要哪些资源。然后添加。不确定或者对系统大小不敏感,可以添加.net 然后进行关联性检查之后删除.net。这样大多数程序都可以在上面运行。

    XPE开发工具本身爱坏,最好安装到虚拟机中。


    2010年1月6日 9:15
    版主
  • 那些组件都加上了,我重新编译了一下系统,在 安装完vc6.0重启的时候提醒 A error occurred loading:"D:\program Files\common File\System\OLE OB\msdatt.dll".The filemay not have been installed or it has been corrupted.
    第二次重启系统的时候就没有这个问题了,我检查过上面那个文件在那个路径下,不知道是不是少加了某个组件?
    XP Embedded 开发
    2010年3月18日 7:06
  • 今天遇到同样的问题,盼有人来解决啊?

     HappyMy能不能说的详细点呢?添加什么.net呢?

    2010年6月23日 13:03
  • .net framework

    另外你系统是在D盘么?

    建议你用filemon监视一下


    肖正波
    诚亚博瑞科技有限公司
    我的WIndows Embedded中文技术BLOG:
    www.XPE.cc
    http://m--y.spaces.live.com/blog/
    QQ:1320232327(另外两个已满)
    MSN:questor_87@hotmail.com
    MCTS:70-571;MCTS:70-577;MCTS:70-582
    Microsoft MVP(2010)
    2010年6月25日 16:14
    版主