none
iis 错误 id 1000 RRS feed

  • 问题

  • 请问大家,以下错误如何解决?

     

    系统为Windows server 2003 ent R2 with Sp2(sp1时亦有此错误),服务器角色是bdc+wsus 3.0

    Faulting application w3wp.exe, version 6.0.3790.3959, faulting module unknown, version 0.0.0.0, fault address 0x001f0017.

    Code Snippet

    Event Type: Error
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1000
    Date:  10/24/2008
    Time:  10:39:33 PM
    User:  N/A
    Computer: DC02
    Description:
    Faulting application w3wp.exe, version 6.0.3790.3959, faulting module unknown, version 0.0.0.0, fault address 0x001f0017.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 70 70 6c 69 63 61 74   Applicat
    0008: 69 6f 6e 20 46 61 69 6c   ion Fail
    0010: 75 72 65 20 20 77 33 77   ure  w3w
    0018: 70 2e 65 78 65 20 36 2e   p.exe 6.
    0020: 30 2e 33 37 39 30 2e 33   0.3790.3
    0028: 39 35 39 20 69 6e 20 75   959 in u
    0030: 6e 6b 6e 6f 77 6e 20 30   nknown 0
    0038: 2e 30 2e 30 2e 30 20 61   .0.0.0 a
    0040: 74 20 6f 66 66 73 65 74   t offset
    0048: 20 30 30 31 66 30 30 31    001f001
    0050: 37                        7      

     

     

    When logging on to a Windows 2003 SP1 with IIS 6.0 every other time, with either Terminal Services or Remote Desktop Connection, sporadically we see an error popup that shows "IIS Worker process error". No IIS / isapi operations seem to be even attempted by us.
     
    Correspondingly, we see the following errors in the Windows Event Log on the server.
     
    1. Source: Application Error, Category: 100, Event ID: 1000, Reason: Faulting application w3wp.exe, version 6.0.3790.1830, faulting module msvcrt.dll, version 7.0.3790.1830, fault address 0x0003399b
     
    2. Source: Application Error, Category: 100, Event ID: 1004, Reason: Faulting application w3wp.exe, version 6.0.3790.1830, faulting module nt.dll, version 7.0.3790.1830, fault address 0x00026f76
     
    3. Source: W3SVC, Category: None, Event ID: 1011, Reason: A process serving application pool 'DefaultAppPool' suffered a fatal communication error with the World Wide Publishing Service. The process id was '4744', the data field contains the error number.
     
    I couldnt find exact matches of these errors in microsoft.com, msdn.microsoft.com
    2008年10月28日 1:10

答案

  • please have a try:

    When you run ASP.NET 2.0 on a domain controller check permissions on the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET_2.0.50727\Names .
    When ASP.NET 2.0 is installed, the local group IIS_WPG is given special permissions on this key. When the server is a domain controller the IIS_WPG group becomes a domain group (there are no local groups on domain controllers) and the NETWORK SERVICE account cannot be a member of it as it is a BUILTIN account. What you will need to do is give the NETWORK SERVICE account specific permissions to that key. Start Regedit and navigate to that key. Right-click "Names" and select “Permissions” on the context menu. Click Add and enter NETWORK SERVICE, click "Check Names" and click "Ok". With NETWORK SERVICE highlighted in the "Groups or User Names" list, click "Advanced". On the "Advanced Security Settings for Names" dialogue highlight NETWORK SERVICE and click "Edit". In the "Permission entry for Names" dialogue check that the "Name" box is showing "NETWORK SERVICE" and put check marks against "Query Value", "Set Value", "Create Subkey", "Enumerate Subkeys", "Notify" and "Read Control". Click Ok on all the dialogues and close Regedit. Ensure your application pools are reconfigured to run as NETWORK SERVICE (or at least all the ones you want to be) and restart them.
    After a restart, there should be no more errors.

    2008年10月28日 1:21
    版主

全部回复

  • please have a try:

    When you run ASP.NET 2.0 on a domain controller check permissions on the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET_2.0.50727\Names .
    When ASP.NET 2.0 is installed, the local group IIS_WPG is given special permissions on this key. When the server is a domain controller the IIS_WPG group becomes a domain group (there are no local groups on domain controllers) and the NETWORK SERVICE account cannot be a member of it as it is a BUILTIN account. What you will need to do is give the NETWORK SERVICE account specific permissions to that key. Start Regedit and navigate to that key. Right-click "Names" and select “Permissions” on the context menu. Click Add and enter NETWORK SERVICE, click "Check Names" and click "Ok". With NETWORK SERVICE highlighted in the "Groups or User Names" list, click "Advanced". On the "Advanced Security Settings for Names" dialogue highlight NETWORK SERVICE and click "Edit". In the "Permission entry for Names" dialogue check that the "Name" box is showing "NETWORK SERVICE" and put check marks against "Query Value", "Set Value", "Create Subkey", "Enumerate Subkeys", "Notify" and "Read Control". Click Ok on all the dialogues and close Regedit. Ensure your application pools are reconfigured to run as NETWORK SERVICE (or at least all the ones you want to be) and restart them.
    After a restart, there should be no more errors.

    2008年10月28日 1:21
    版主
  •  

    谢谢,观察中……
    2008年10月29日 8:14
  • 你正在观察怎么样?情况怎么样啊?我现在是共享不了

    2008年11月13日 6:38