none
Visual Studio Community 2019 16.2.3 开启预览版SDK无效 RRS feed

  • 问题

  • 如题

    1.已经安装 .net core 3.0.100-preview8-013656

    2.已经勾选开启预览版SDK选项,并重启

    3.创建项目时没有 3.0 选择

    4.但是用2.2创建好以后,修改项目属性,可以切换成 3.0 版本

    5.已经重装过

    安装顺序:重装系统,安装VS2019,安装.NET CORE 3.0

    发现无效,重置VS2019配置,重新勾选并重启VS2019,依旧无效。

    VS 版本截图

    2019年8月22日 17:09

答案

  • Hi Johan,

    欢迎来到MSDN论坛。

    .Net Core 3.0.100-preview 8需要16.3及以上的vs版本。你可以参考这个官方文档。因此我们不太推荐在你的vs版本上安装.Net Core 3.0 preview 8。

    你可以参考这个类似的问题:

    https://developercommunity.visualstudio.com/content/problem/692954/net-core-30-preview-8-cant-be-used-in-vs-162.html

      1. 但是我们推荐你安装visual studio community 2019 preview 版本。我在我的环境能成功安装并创建带有.Net Core 3.0的项目。在使用期间也没有任何问题。

    > >顺便说一句,你也可以在安装好vs preview版本之后,再试试启动你的vs community 2019 试试。

      2. 或者就直接在你的visual studio 2019 community上安装.Net Core 3.0 preview 6版本

    希望能帮助到你。

    Best Regards,

    Perry



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com



    2019年8月23日 9:40

全部回复

  • Hi Johan,

    欢迎来到MSDN论坛。

    .Net Core 3.0.100-preview 8需要16.3及以上的vs版本。你可以参考这个官方文档。因此我们不太推荐在你的vs版本上安装.Net Core 3.0 preview 8。

    你可以参考这个类似的问题:

    https://developercommunity.visualstudio.com/content/problem/692954/net-core-30-preview-8-cant-be-used-in-vs-162.html

      1. 但是我们推荐你安装visual studio community 2019 preview 版本。我在我的环境能成功安装并创建带有.Net Core 3.0的项目。在使用期间也没有任何问题。

    > >顺便说一句,你也可以在安装好vs preview版本之后,再试试启动你的vs community 2019 试试。

      2. 或者就直接在你的visual studio 2019 community上安装.Net Core 3.0 preview 6版本

    希望能帮助到你。

    Best Regards,

    Perry



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com



    2019年8月23日 9:40
  • 确实如您所言,VS与.NET CORE 3不同的预览版本有要求,现在安装 .Net Core 3.0 preview 6版本就好了

    2019年8月23日 14:35