locked
请教一个XPE反复重起问题~~~~~~ RRS feed

  • 问题

  •  

    请各位高手 帮忙分析一下问题 ~~~

      我手上有个 XPE  在用一段时间后出现反复重起的现象,

    就是系统在快进入桌面的那个 欢迎界面的 时候就 反复重起,就只自动断电重起 ,

     

     还有一种现象是  我有一个嵌入式设备上面装的是一个XPE ,我把硬盘拿下来,

      放在另一个嵌入式设备(同一型号,配置一样,相同的设备)下启动XPE 也是在 那个欢迎界面的时候

    反复重起,但是可以正常进安全模式,谁知道 是什么问题呢,

     简单点说 就是在另外一台相同的机器上启动这个XPE的时候 就出现反复重起,把硬盘放回原来的机器上就正常

    ,是不是有什么限制啊~~~~

    2008年12月11日 5:55

答案

  • 针对XPE反复重启的问题,

    首先保证你的硬盘是按照以下方式分区格式化的,如果不是,请按照以下方式重新分区,格式化,激活硬盘:

    1。如果是把XPE部署在C盘上,则需要在XPE工程中设置ARC路径为multi(0)disk(0)rdisk(0)partition(1),如果是D盘上,则需要设置ARC路径为multi(0)disk(0)rdisk(0)partition(2),依次类推;

    2。如果把XPE部署在C盘上,把硬盘主分区格式化成NTFS格式,同时激活主分区,然后把XPE生成的镜像文件拷贝到主分区,以该硬盘启动,即可进行FBA;

    3。如果把XPE部署在D盘上,则需要修改原C盘上的boot.ini文件,添加语句:

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Embedded" /noexecute=optin /fastdetect

    其次按照以下内容进行检查:

    1.确定你的设备文件(.pmq)是在本机生成的,并且主要硬件驱动组件已经添加到XPE工程中;

    2.正确的设置目标磁盘大小和簇大小设置的值,例如目标分区是10G,则目标盘大小应该设为10*1024;

    3.确定你的原有XPE操作系统没有安装类似于引导启动时的病毒检测软件;

    4.确定你的机器上面使用的是单硬盘,并且不是SCSI接口的;

    5.确定在FBA的时候,机器上没有连接任何USB设备和串口设备,打印机及其他外设;

    6.确定你使用了合法的PID号,如果不能确定可以先把PID删掉或换一个PID试试;

    7.确保你的目标机在部署的时候具有256M以上的物理内存空间,如果没有,则需要设置File page Size;

    8.确保你的目标机具有足够的磁盘空间,一般建议在512M以上,当然,如果你做出来的XPE小于200M,可以使用256M的磁盘;

    9.如果使用了EWF功能,检查EWF设置是否正常;

    10.开始做XPE的时候,建议使用硬盘来做,如果用CF卡、DOM、IDE-FLASH会有许多以外的问题出现,为了保证最大的成功率,建议开始使用硬盘来做,而且只接入一块硬盘;

    如果您的 FBA 反复重新启动,则这意味着您为错误的分区生成了运行库。目标设计器默认情况下使用 C:\,因此您必须更改目标计算机上的目标分区。检查位于 .\windows\fba\fbalog.txt 的 fbalog.txt 的开头。如果看到指出“invalid path”的错误,则这就是问题所在。

    要解决该问题,请在目标设计器内,单击中心窗格中的 Settings。然后,选择 Target Device Settings。启动驱动器可能被正确设置为 C:,但是 Windows 文件夹、Program Files 文件夹以及 Docs and Settings 文件夹可能需要将它们的驱动器号从 C: 更改为正确的驱动器号。这将是 RealMode 中指示的驱动器号(就好像来自从 Microsoft MS-DOS? 运行的 fdisk)。它并不总是与 Windows 分配的驱动器号相同。

    First Boot Agent 创建了可以用来进行疑难解答的日志。它位于运行库中的 .\windows\FBA\FBALOG.txt。它列出了所注册的每个二进制文件、绑定到网络接口卡 (NIC) 的协议、找到的即插即用 (PnP) 设备、错误以及更多内容。

    2008年12月12日 6:43
    版主

全部回复

  • 这个应该属于你两套设备硬件的设置问题我怀疑,看看两个设备的BIOS是不是设置一样,

    我曾经就这样做过呀,但是没有出现你说的问题,在一台上面装好,然后拿到另一台上面

    没有问题,而且你也说可以正常进入安全模式,因为安全模式只是加载系统必须的进程,

    显卡呀 声卡驱动都不会加载 所以你看看是那里设置的不一样!!

     

    2008年12月12日 1:07
    版主
  • 我两套设备是一样的东西,BIOS  都还原了默认设置,我在安全模式下,把显卡驱动卸载过,还是一样,

    就是搞不懂 是怎么会事~~~~我测试了一下 我自己从新开发的系统同一个硬盘在两个同样的设备上启动 没问题,

    别人的随机器一起带的XPE系统 就只能在原来的那个设备上启动,同样的另一个设备 就出现这个反复重起现象。

    2008年12月12日 2:20
  •  

    难怪,估计是人家做的加密 防克隆吧,

    对了 你可以把他们那个GHOST起来 然后恢复回去 到另一台设备上看看!!

    2008年12月12日 6:10
    版主
  • 针对XPE反复重启的问题,

    首先保证你的硬盘是按照以下方式分区格式化的,如果不是,请按照以下方式重新分区,格式化,激活硬盘:

    1。如果是把XPE部署在C盘上,则需要在XPE工程中设置ARC路径为multi(0)disk(0)rdisk(0)partition(1),如果是D盘上,则需要设置ARC路径为multi(0)disk(0)rdisk(0)partition(2),依次类推;

    2。如果把XPE部署在C盘上,把硬盘主分区格式化成NTFS格式,同时激活主分区,然后把XPE生成的镜像文件拷贝到主分区,以该硬盘启动,即可进行FBA;

    3。如果把XPE部署在D盘上,则需要修改原C盘上的boot.ini文件,添加语句:

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Embedded" /noexecute=optin /fastdetect

    其次按照以下内容进行检查:

    1.确定你的设备文件(.pmq)是在本机生成的,并且主要硬件驱动组件已经添加到XPE工程中;

    2.正确的设置目标磁盘大小和簇大小设置的值,例如目标分区是10G,则目标盘大小应该设为10*1024;

    3.确定你的原有XPE操作系统没有安装类似于引导启动时的病毒检测软件;

    4.确定你的机器上面使用的是单硬盘,并且不是SCSI接口的;

    5.确定在FBA的时候,机器上没有连接任何USB设备和串口设备,打印机及其他外设;

    6.确定你使用了合法的PID号,如果不能确定可以先把PID删掉或换一个PID试试;

    7.确保你的目标机在部署的时候具有256M以上的物理内存空间,如果没有,则需要设置File page Size;

    8.确保你的目标机具有足够的磁盘空间,一般建议在512M以上,当然,如果你做出来的XPE小于200M,可以使用256M的磁盘;

    9.如果使用了EWF功能,检查EWF设置是否正常;

    10.开始做XPE的时候,建议使用硬盘来做,如果用CF卡、DOM、IDE-FLASH会有许多以外的问题出现,为了保证最大的成功率,建议开始使用硬盘来做,而且只接入一块硬盘;

    如果您的 FBA 反复重新启动,则这意味着您为错误的分区生成了运行库。目标设计器默认情况下使用 C:\,因此您必须更改目标计算机上的目标分区。检查位于 .\windows\fba\fbalog.txt 的 fbalog.txt 的开头。如果看到指出“invalid path”的错误,则这就是问题所在。

    要解决该问题,请在目标设计器内,单击中心窗格中的 Settings。然后,选择 Target Device Settings。启动驱动器可能被正确设置为 C:,但是 Windows 文件夹、Program Files 文件夹以及 Docs and Settings 文件夹可能需要将它们的驱动器号从 C: 更改为正确的驱动器号。这将是 RealMode 中指示的驱动器号(就好像来自从 Microsoft MS-DOS? 运行的 fdisk)。它并不总是与 Windows 分配的驱动器号相同。

    First Boot Agent 创建了可以用来进行疑难解答的日志。它位于运行库中的 .\windows\FBA\FBALOG.txt。它列出了所注册的每个二进制文件、绑定到网络接口卡 (NIC) 的协议、找到的即插即用 (PnP) 设备、错误以及更多内容。

    2008年12月12日 6:43
    版主
  •  

    可能 是做了 什么加密  我用GHOST 打包 然后在还原还是一样,在另一台机器上还是反复重起

    硬盘,分区  还原 都试过了  ,还原带 原本的那台机器就没什么问题,

    就是在进系统 欢迎界面的 时候 就断电重起了,  不是在FBA 的时候重起。

    可能是做了什么东西加密了~~~

    2008年12月13日 1:49