none
怎么把项目从.net 4.6升级到4.6.2 RRS feed

  • 问题

  • 我用的vs2017,编译时候遇到如下问题.
    未能解析主引用“AdsJumboWinForm, Version=1.0.0.0, Culture=neutral, PublicKeyToken=d4c9423ef164f081, processorArchitecture=MSIL”,因为它是针对“.NETFramework,Version=v4.6.2”框架生成的。该框架版本高于当前目标框架“.NETFramework,Version=v4.6”。 WindowsFormsApp1

    我想把我的项目升级到4.6.2,请问应该怎么做?

    2021年1月14日 1:20

答案

  • 你好 BillQu002,

    首先你需要检查你是否可以使用.net framework 4.6.2,请右击你的项目->选择属性看下你有没有4.6.2。

    如果像下面这样,就是没有4.6.2的。

    其次你可以点击Install Other frameworks然后就会转到 Download .NET SDKs for Visual Studio 这个网站,在这个里面找到.net framework4.6.2这个,点击对应的Developer Pack进行下载。

    最后,下载完成后,点击exe进行安装,安装完成后,重新启动visual studio,你就会看到下面的界面。

    选择.NET Framework4.6.2然后在rebuild你的项目应该就可以了。

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    2021年1月14日 6:42
    版主

全部回复

  • 你好 BillQu002,

    首先你需要检查你是否可以使用.net framework 4.6.2,请右击你的项目->选择属性看下你有没有4.6.2。

    如果像下面这样,就是没有4.6.2的。

    其次你可以点击Install Other frameworks然后就会转到 Download .NET SDKs for Visual Studio 这个网站,在这个里面找到.net framework4.6.2这个,点击对应的Developer Pack进行下载。

    最后,下载完成后,点击exe进行安装,安装完成后,重新启动visual studio,你就会看到下面的界面。

    选择.NET Framework4.6.2然后在rebuild你的项目应该就可以了。

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    2021年1月14日 6:42
    版主
  • 谢谢了!
    2021年1月15日 0:14