locked
部署在优盘上的WES7启动不了 RRS feed

  • 问题

  • 我在瘦机硬盘上装了一个WES7,用的是瘦机模板,加载了Bootable Windows USB Stack,依赖关系也选择的是Bootable Windows USB Stack。但是我用imageX提取硬盘镜像并部署到一个空白优盘上后,用该优盘启动不了其它同样类型的瘦机。
    2012年10月29日 3:18

答案

  • winload 0xC000000E 是引导问题。我看你也解决了。

    diskpart对可移动磁盘是无效的

    其他的看我刚回的帖子。


    肖正波 / Zhengbo.Xiao
    销售微软软件授权、技术支持及相关培训
    深圳艾斯威特贸易有限公司
    www.iswtt.com
    我的WIndows Embedded中文技术BLOG(海外):
    http://questor87.wordpress.com/
    我的WIndows Embedded中文技术BLOG(国内):
    http://blog.sina.com.cn/windowsembedded
    QQ:1320232327(另外两个已满)
    MSN:questor_87@hotmail.com
    MCTS:
    Windows Embedded Standard 7 Development
    Windows Embedded Standard 2009 Development
    Windows Embedded Standard CE Development
    Microsoft MVP(2010-2012)

    2012年11月3日 14:41
    版主

全部回复

  • 该U盘是否执行过以下相关操作:

    diskpart

    >list disk

    >select disk x(您的u盘)

    >clean

    >create par pri

    >format fs=ntfs

    >active

    >exit


    Stay Running


    MCTS:
    Windows Embedded Standard 2011,Development
    Windows Embedded Standard 2009,Development
    MSN:chenghufan@hotmail.com
    Beijing Strong Union Technology CO., Ltd.

    2012年11月1日 7:03
    版主
  • 这些操作是做过的。将优盘插在样本机上能正常启动,但启动的却是样本机硬盘上的操作系统,用在其他同类机器上则报winload 0xC000000E故障。

    样本机的操作系统是用无人值守映像安装的,我在制作这个映像时,应答文件里的磁盘配置信息如下:

                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Type>Primary</Type>
                                <Extend>true</Extend>
                            </CreatePartition>
                        </CreatePartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <PartitionID>1</PartitionID>
                            <DiskID>0</DiskID>
                        </InstallTo>
                        <InstallToAvailablePartition>false</InstallToAvailablePartition>
                    </OSImage>
                </ImageInstall>

    没有涉及常规安装时出现的100M系统分区,不知道是不是这个原因引起的问题?

    样机上运行diskpart——list partition没有找到系统分区的信息,imagex也没有把这个分区里的东西抓到vim映像里。

    我试过不设磁盘配置信息而是在选择安装位置时手动选取目标优盘。

    经过两百多分钟的安装后,这个优盘算是实现跨机启动了,但在Windows欢迎画面出现前一刻,整个系统蓝屏死机。

    整个WES7sp1从定制到安装(包括映像形式部署),环节蛮多的。

    现在搞不清answer files、imageX、BCD或是其他什么地方出了问题,所以想请教一下。
    2012年11月3日 4:22
  • winload 0xC000000E 是引导问题。我看你也解决了。

    diskpart对可移动磁盘是无效的

    其他的看我刚回的帖子。


    肖正波 / Zhengbo.Xiao
    销售微软软件授权、技术支持及相关培训
    深圳艾斯威特贸易有限公司
    www.iswtt.com
    我的WIndows Embedded中文技术BLOG(海外):
    http://questor87.wordpress.com/
    我的WIndows Embedded中文技术BLOG(国内):
    http://blog.sina.com.cn/windowsembedded
    QQ:1320232327(另外两个已满)
    MSN:questor_87@hotmail.com
    MCTS:
    Windows Embedded Standard 7 Development
    Windows Embedded Standard 2009 Development
    Windows Embedded Standard CE Development
    Microsoft MVP(2010-2012)

    2012年11月3日 14:41
    版主