none
在win10子系统ubuntu中安装kernel-package时报错。说/proc/devices 无法打开。 RRS feed

  • 问题

  • 本人尝试在win10的子系统ubuntu中安装kernel-package时,提示需要安装些附加软件,然后下载完之后就报错。

    具体错误如下:

    ***@DELL-IT-4:/etc/kernel$ sudo apt-get install kernel-package
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libaio1 libapache2-mod-php5 libdbd-mysql-perl libdbi-perl libmysqlclient18 libreadline5 mariadb-client-10.0
      mariadb-client-core-10.0 mariadb-common mariadb-server-core-10.0 mysql-common os-prober php5-cli php5-common
      php5-json php5-readline
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      dblatex docbook-dsssl docbook-utils docbook-xml docbook-xsl fonts-lmodern fonts-texgyre gettext intltool-debian
      jadetex kernel-common libasprintf-dev libauthen-sasl-perl libfile-basedir-perl libfile-desktopentry-perl
      libfile-homedir-perl libfile-listing-perl libfile-mimeinfo-perl libfile-which-perl libfont-afm-perl libfontenc1
      libgettextpo-dev libgettextpo0 libgl1-mesa-glx libglapi-mesa libharfbuzz-icu0 libhtml-form-perl libhtml-format-perl
      libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-negotiate-perl libio-socket-ssl-perl
      libipc-system-simple-perl libjs-jquery libkpathsea6 liblwp-protocol-https-perl libmail-sendmail-perl
      libmailtools-perl libnet-dbus-perl libnet-http-perl libnet-smtp-ssl-perl libnet-ssleay-perl libosp5 libostyle1c2
      libpoppler52 libpotrace0 libptexenc1 libruby2.1 libsgmls-perl libsp1c2 libsynctex1 libsys-hostname-long-perl
      libtcl8.6 libtexlua52 libtexluajit2 libtie-ixhash-perl libtk8.6 libunistring0 libwww-perl libwww-robotrules-perl
      libx11-protocol-perl libxaw7 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-shape0 libxcb-sync1 libxml-parser-perl
      libxml-twig-perl libxml-xpathengine-perl libxml2-utils libxmu6 libxshmfence1 libxss1 libxv1 libxxf86dga1 libxxf86vm1
      libyaml-tiny-perl libzzip-0-13 lmodern openjade po-debconf preview-latex-style prosper ps2eps ruby ruby2.1
      rubygems-integration sgml-data sgmlspl sp tcl tcl8.6 tex-common tex-gyre texlive texlive-base texlive-bibtex-extra
      texlive-binaries texlive-extra-utils texlive-font-utils texlive-fonts-recommended texlive-fonts-recommended-doc
      texlive-generic-recommended texlive-latex-base texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc
      texlive-latex-recommended texlive-latex-recommended-doc texlive-math-extra texlive-pictures texlive-pictures-doc
      texlive-pstricks texlive-pstricks-doc tipa tk tk8.6 unzip x11-utils x11-xserver-utils xbitmaps xdg-utils xmlto
      xsltproc xterm zip
    Suggested packages:
      docbook graphicsmagick-imagemagick-compat imagemagick latex-cjk-all opensp pdf-viewer texlive-lang-all
      texlive-lang-cyrillic texlive-xetex transfig docbook-dsssl-doc docbook-defguide dbtoepub docbook-xsl-doc-html
      docbook-xsl-doc-pdf docbook-xsl-doc-text docbook-xsl-doc docbook-xsl-saxon fop libsaxon-java libxalan2-java
      libxslthl-java xalan gettext-doc linux-source libncurses-dev libdigest-hmac-perl libgssapi-perl javascript-common
      libcrypt-ssleay-perl sgmls-doc libauthen-ntlm-perl libunicode-map8-perl libunicode-string-perl xml-twig-tools
      doc-base libmail-box-perl ri ruby-dev bundler perlsgml w3-recs tcl-tclreadline debhelper perl-tk latexmk chktex
      lacheck latexdiff xindy purifyeps fragmaster dvidvi dvipng t1utils psutils libspreadsheet-parseexcel-perl
      python-pygments dot2tex libtcltk-ruby prerex mesa-utils nickle cairo-5c xorg-docs-core gvfs-bin xmltex
      xfonts-cyrillic
    Recommended packages:
      uboot-mkimage wish
    The following NEW packages will be installed:
      dblatex docbook-dsssl docbook-utils docbook-xml docbook-xsl fonts-lmodern fonts-texgyre gettext intltool-debian
      jadetex kernel-common kernel-package libasprintf-dev libauthen-sasl-perl libfile-basedir-perl
      libfile-desktopentry-perl libfile-homedir-perl libfile-listing-perl libfile-mimeinfo-perl libfile-which-perl
      libfont-afm-perl libfontenc1 libgettextpo-dev libgettextpo0 libgl1-mesa-glx libglapi-mesa libharfbuzz-icu0
      libhtml-form-perl libhtml-format-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl
      libhttp-negotiate-perl libio-socket-ssl-perl libipc-system-simple-perl libjs-jquery libkpathsea6
      liblwp-protocol-https-perl libmail-sendmail-perl libmailtools-perl libnet-dbus-perl libnet-http-perl
      libnet-smtp-ssl-perl libnet-ssleay-perl libosp5 libostyle1c2 libpoppler52 libpotrace0 libptexenc1 libruby2.1
      libsgmls-perl libsp1c2 libsynctex1 libsys-hostname-long-perl libtcl8.6 libtexlua52 libtexluajit2 libtie-ixhash-perl
      libtk8.6 libunistring0 libwww-perl libwww-robotrules-perl libx11-protocol-perl libxaw7 libxcb-dri3-0 libxcb-glx0
      libxcb-present0 libxcb-shape0 libxcb-sync1 libxml-parser-perl libxml-twig-perl libxml-xpathengine-perl libxml2-utils
      libxmu6 libxshmfence1 libxss1 libxv1 libxxf86dga1 libxxf86vm1 libyaml-tiny-perl libzzip-0-13 lmodern openjade
      po-debconf preview-latex-style prosper ps2eps ruby ruby2.1 rubygems-integration sgml-data sgmlspl sp tcl tcl8.6
      tex-common tex-gyre texlive texlive-base texlive-bibtex-extra texlive-binaries texlive-extra-utils texlive-font-utils
      texlive-fonts-recommended texlive-fonts-recommended-doc texlive-generic-recommended texlive-latex-base
      texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc texlive-latex-recommended
      texlive-latex-recommended-doc texlive-math-extra texlive-pictures texlive-pictures-doc texlive-pstricks
      texlive-pstricks-doc tipa tk tk8.6 unzip x11-utils x11-xserver-utils xbitmaps xdg-utils xmlto xsltproc xterm zip
    0 upgraded, 129 newly installed, 0 to remove and 16 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/768 MB of archives.
    After this operation, 1,283 MB of additional disk space will be used.
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    E: Can not write log (Is /dev/pts mounted?) - posix_openpt (2: No such file or directory)
    Setting up fuse (2.9.4-1ubuntu1) ...
    libkmod: ERROR ../libkmod/libkmod-module.c:1655 kmod_module_new_from_loaded: could not open /proc/modules: No such file or directory
    Error: could not get list of modules: No such file or directory
    Creating fuse device...
    /sbin/MAKEDEV: warning: can't read /proc/devices
    mknod: ‘fuse-’: Function not implemented
    makedev fuse c 10 229 root root 0660: failed
    chmod: cannot access ‘/dev/fuse’: No such file or directory
    dpkg: error processing package fuse (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     fuse
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    请问如何解决?

    --

    2016年6月8日 8:20