none
如何简便得检测网站使用的框架和类库的是否过时? RRS feed

  • 问题

  • 使用一些过时的框架和类库有可能引起兼容性问题,有没有工具能够快速检查出的网站使用的框架和类库的版本信息。
    2016年4月12日 8:38

答案

  • 你好,

    建议使用兼容性检查工具Compat Inspector协助进行检查,它可以检测并且报告你所使用的库的版本,并帮助检查是否存在兼容性问题。如果你要了解如何使用Compat Inspector,请你访问这里:http://akms/compat_inspector

     

    1 使用dev.modern.ie网站检测:

    点击链接https://dev.windows.com/zh-cn/microsoft-edge/tools/staticscan/在输入框输入网站URL,点击查询即可检测网站问题:

     

    如果出现“框架和库”问题,如下图所示:

     

     

    2 使用框架与类库的建议版本

    为了给用户提供优秀的用户体验,达到最好的兼容效果,请使用表A-4中列出的框架与类库的建议版本。如果你希望手动检查你的框架与类库,请你对照表A-4,确保升级到相应的版本。注意,框架版本针对不同的版本前缀其最低版本要求不同,如jQuery1.6.*的最低要求为1.6.4,而对于1.7.*的要求为1.7.2,其他与此类似。

     

    框架与类库

    版本前缀

    最低位

    最新

    Prototype

    1.7

    2

    1.7.2

    Dojo

    1.5

    3

    1.10.4

     

    1.6

    2

     

     

    1.7

    5

     

     

    1.8

    5

     

     

    1.9

    2

     

     

    1.10

    0

     

    Mootools

    1.2

    6

    1.5.1

     

    1.4

    5

     

     

    1.5

     

     

    SWFObject

    2.

    2

    2.2

    jQuery Form Plugin

    3.

    22

    3.46

    Modernizr

    2.5

    2

    2.8.3

     

    2.6

    2

     

     

    2.7

    1

     

     

    2.8

    3

     

    jQuery cookie

    1.3

    1

    1.4.1

     

    1.4

    1

     

    hoverIntent

    1.8

    1

    1.8.1

    jQuery Easing

    1.3

    0

    1.3.1

    Underscore

    1.5

    2

    1.8.3

     

    1.6

    0

     

     

    1.7

    0

     

     

    1.8

    3

     

    hammer js

    2.0

    4

    2.0.4

    jQuery Superfish

    1.7

    4

    1.7.4

    jQuery mousewheel

    3.1

    12

    3.1.12

    jQuery mobile

    1.3

    2

    1.4.5

     

    1.4

    5

     

    jQuery UI

    1.8

    24

    1.11.4

     

    1.9

    2

     

     

    1.10

    4

     

     

    1.11

    4

     

    jQuery

    1.6

    4

    1.11.3

     

    1.7

    2

     

     

    1.8

    2

     

     

    1.9

    1

     

     

    1.10

    2

     

     

    1.11

    3

     

     

    2.0

    3

     2.1.4

     

    2.1

    4

      

    A‑4框架和类库的建议版本列表

    2016年4月12日 8:54