none
管理工具里没有“Microsoft .NET Framework 2.0配置”这一项 RRS feed

  • 问题

  • 请问:我的系统是XP_XP2,安装了.NET Framework 2.0和中文语言包,没有安装VS产品,现在可以运行VS2005写的程序了,说明.NET Framework安装成功了,但在管理工具里没有“Microsoft .NET Framework 2.0配置”这一项,请问是怎么回事,或者说如何才能配置这种电脑上的.NET安全性?
    2008年2月28日 5:36

答案

  • 这个地方MS貌似偷懒了,或者有其他理由……

    只有安装了.Net Framework 2.0 SDK之后才会在管理工具中添加

    “Microsoft .NET Framework 2.0配置”,但是在部署的时候显然不能因为要个

    “Microsoft .NET Framework 2.0配置”就安装一套SDK。

    没办法,只能通过命令行工具caspol.exe进行安全性配置,比较麻烦,具体可以到网上查查caspol怎么用……

    2008年2月28日 7:53
    版主

全部回复

  • 确实没有,只有1.1的配置,应该就是这么设置的,没有其他原因。

    2008年2月28日 5:50
    版主
  •  WilsonWu 写:

    确实没有,只有1.1的配置,应该就是这么设置的,没有其他原因。



    谢谢回复,那请问我如何配置.NET Framework的安全性?
    我的目的是运行网络上其他主机上的程序,此程序每天都在修改,老是拷贝到本地再运行会很繁琐,记得.NET Framework 1.1时可通过设置区域安全性而达到要求,请问在.NET Framework 2.0下如何做?
    2008年2月28日 6:17
  • 这个地方MS貌似偷懒了,或者有其他理由……

    只有安装了.Net Framework 2.0 SDK之后才会在管理工具中添加

    “Microsoft .NET Framework 2.0配置”,但是在部署的时候显然不能因为要个

    “Microsoft .NET Framework 2.0配置”就安装一套SDK。

    没办法,只能通过命令行工具caspol.exe进行安全性配置,比较麻烦,具体可以到网上查查caspol怎么用……

    2008年2月28日 7:53
    版主
  •  RickyLin 写:

    这个地方MS貌似偷懒了,或者有其他理由……

    只有安装了.Net Framework 2.0 SDK之后才会在管理工具中添加

    “Microsoft .NET Framework 2.0配置”,但是在部署的时候显然不能因为要个

    “Microsoft .NET Framework 2.0配置”就安装一套SDK。

    没办法,只能通过命令行工具caspol.exe进行安全性配置,比较麻烦,具体可以到网上查查caspol怎么用……

    只这是微软的过错.看来又要去MSDN了
    2008年2月28日 11:49
  • 请问具体如何用caspol.exe配置所有区域代码的安全性都为"FullTrust"?就像1.1时一样?
    2008年2月29日 0:46
  •  Jeefis 写:
    请问具体如何用caspol.exe配置所有区域代码的安全性都为"FullTrust"?就像1.1时一样?
    他的意思就是让你去百度或是谷歌?Do you understand?
    2008年3月2日 3:05