none
web.config RRS feed

  • 问题

  • 大家帮我看看这是什么情况啊
     

    “/”应用程序中的服务器错误。

    配置错误

    说明: 在处理向该请求提供服务所需的配置文件时出错。请检查下面的特定错误详细信息并适当地修改配置文件。

    分析器错误消息: 各个节在每个配置文件中只能出现一次。有关异常的信息,请参阅帮助主题 <location>。

    源错误:

    行 40: </system.web> 行 41: 行 42: <appSettings> 行 43:    <add key="sqlconnect" value="Data Source=10.150.51.21;Initial Catalog=LifeService;User ID=sa;Password=123"/> 行 44: </appSettings>

    源文件: D:\vspj\lifeservice\lifeservice\web.config    行: 42


    版本信息: Microsoft .NET Framework 版本:2.0.50727.3074; ASP.NET 版本:2.0.50727.3074

    vista 系统的
    • 已移动 桂素伟Moderator 2009年3月21日 8:44 (从 Visual C# 移动到 ASP.NET 与 AJAX)
    2009年3月20日 8:42

答案

  • 标签有错误,注意检查标签的大小写格式,web.config是大小写很敏感的配置。
    jon.valett@gmail.com
    2009年3月20日 11:17
    版主
  • 你最好重新手写过,不能保证从别的地方复制来的,会有编码上的原因,把一些其他字符也复制过来了,但是你看不到。同时,虽然错误提示是在上面那里提示错误的,但是最好也要把其他设置看一下,IDE有时候也会不准确的。
    jon.valett@gmail.com
    2009年3月20日 11:31
    版主
  • 你好,请检查<appSettings>节点,各个节在每个配置文件中只能出现一次。
    jon.valett@gmail.com
    2009年3月20日 9:03
    版主
  • 你好!
         每个配置文件里只能有一个<appsettings>节点,检查一下是否你的配置文件中存在多个这个节点! 

    周雪峰
    2009年3月20日 10:03
    版主
  •  应该是出现多个了
    YiChao Ding 一个为了理想而奋斗的青年
    2009年3月20日 10:20
  • 请检查一下 appSetting 节中的元素是否都正确~
    宠辱不惊,看庭前花开花落。去留无意,望天上云卷云舒。
    2009年3月20日 11:29
    版主

全部回复

  • 你好,请检查<appSettings>节点,各个节在每个配置文件中只能出现一次。
    jon.valett@gmail.com
    2009年3月20日 9:03
    版主
  • 你好!
         每个配置文件里只能有一个<appsettings>节点,检查一下是否你的配置文件中存在多个这个节点! 

    周雪峰
    2009年3月20日 10:03
    版主
  •  应该是出现多个了
    YiChao Ding 一个为了理想而奋斗的青年
    2009年3月20日 10:20
  • 的确是有两个,但把那个删掉了以后又出了这个:
    说明: 在处理向该请求提供服务所需的配置文件时出错。请检查下面的特定错误详细信息并适当地修改配置文件。

    分析器错误消息: 该配置节不能包含 CDATA 或文本元素。

    源错误:

    行 2: 行 3: <configuration> 行 4: <appSettings> 行 5:    <add key="sqlconnect" value="Data Source=10.150.51.21;Initial Catalog=LifeService;User ID=sa;Password=TIANgong123"/> 行 6: </appSettings>

    2009年3月20日 10:49
  • 标签有错误,注意检查标签的大小写格式,web.config是大小写很敏感的配置。
    jon.valett@gmail.com
    2009年3月20日 11:17
    版主
  • <appSettings> 
               <add key="sqlconnect" value="Data Source=10.150.51.21;Initial Catalog=LifeService;User ID=sa;Password=123"></add> 
          </appSettings> 
    看那字体颜色,应该也没有输错的吧
    2009年3月20日 11:27
  • 请检查一下 appSetting 节中的元素是否都正确~
    宠辱不惊,看庭前花开花落。去留无意,望天上云卷云舒。
    2009年3月20日 11:29
    版主
  • 你最好重新手写过,不能保证从别的地方复制来的,会有编码上的原因,把一些其他字符也复制过来了,但是你看不到。同时,虽然错误提示是在上面那里提示错误的,但是最好也要把其他设置看一下,IDE有时候也会不准确的。
    jon.valett@gmail.com
    2009年3月20日 11:31
    版主
  • 哎呀果然好了,真是神
    2009年3月20日 11:39