none
cluster sqlserver 2005中的awe问题 RRS feed

  • 问题

  • 我在两个节点的c:\boot.ini文件中都有添加/pae参数。

    而且也查看了下 在两个节点上的lock page in memory中都有添加sqlserver的启动账号。

    之后去sqlserver中执行sp_configure中显示AWE未启动。

    于是执行

    sp_configure 'awe enabled' ,1

    reconfigure

    go

    之后执行

    sp_configure 'max server memory' ,6000

    reconfigure

    go

    sp_configure 'min server memory' ,4000

    reconfigure

    但是提示:

    Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process.

    那我要使用什么账号进去才能执行上面的命令呢?

     


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月18日 3:14

全部回复

  • Double check local security settings on both nodes again. Did you connect to sql as sysadmin? How much memory do those nodes have? Are they 32-bit machines?
    2011年5月18日 3:25
  • yeah。I am sure that all the sql server service starting account has been added into the 'Lock pages in memory' option。

    and i have no the sqladmin(operating account) password.so i can only connect to it using another domain user,then access database using sa.

    But it can't work.

    each node has 8 GB memory.

    32 bit OS.


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月18日 3:33
  • Did you reboot machines after adding /pae in boot.ini file? Did you get error when enable awe? Did you restart sql after enabling awe?
    2011年5月18日 3:36
  • Or it needs me to access to the cluster using sqladmin(sqlserver service start account),then i can modify the awe configuration?
    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月18日 3:45
  • No, sa should be fine. When did you get error? When enable awe or set max memory?
    2011年5月18日 3:49
  • yeah .

    when i run sp_configure 'allow updates',1

    it still show error.

    i don't know why.

    the same error

     

    Configuration option 'allow updates' changed from 1 to 1. Run the RECONFIGURE statement to install.
    Msg 5845, Level 16, State 1, Line 3
    Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process.


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月18日 3:51
  • What's sql service pack level?
    2011年5月18日 3:57
  • SQLServer 2005 STD SP3
    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月18日 4:04
  • Only enterprise edition supports awe.
    2011年5月18日 13:22
  • sorry 记错了 是企业办的额.


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月18日 13:40
  • Confused, why run sp_configure 'allow updates',1? Restart sql then check awe setting again.
    2011年5月18日 13:57
  • 因为是sql的cluster 所以我当时是进行的群集转移.那么也就是有重启sql

    当时是先重启的inactive的节点,之后再重启active的节点的.

     


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.

    2011年5月18日 14:00
  • Did you restart sql after running "sp_configure 'awe enabled' ,1"?
    2011年5月18日 14:53
  • Did you restart sql after running "sp_configure 'awe enabled' ,1"?
    of course.i restart the sqlserver service after running sp_configure
    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月19日 0:30
  • but when i run "reconfigure" in SSMS,

    it shows one error.

    Ad hoc update to system catalogs is not supported.

     


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月19日 0:32
  • it should run the sp_configure like this:

    exec sp_configure 'allow updates',1

    go

    reconfigure

    go

    then run the following

    exec sp_configure 'awe enabled',1

    go

    reconfigure

    go

    exec sp_configure 'min server memory',5000

    go

    reconfigure

    go

    exec sp_configure 'max server memory',5600

    go

    reconfigure

    go

    when running all the statements,move the sql cluster to another node

    then execute gpupdate on each node command window


    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月19日 0:46
  • Don't run "sp_configure 'allow updates',1", you can't change system tables in sql2k5 and up.

    2011年5月19日 0:58
  • OK thanks
    If you haven't all the things you want,be grateful for the things you don't have that you didn't want.
    2011年5月19日 1:26