none
aps.net配置:安全 RRS feed

  • 问题

  • 选择安全页,系统提示

    选定的数据存储区出现问题,原因可能是服务器名称或凭据无效,或者权限不足。也可能是未启用角色管理器功能造成的。请单击下面的按钮,以重定向到可以选择新数据存储区的页。

    下面的消息可能会有助于诊断问题: 无法连接到 SQL Server 数据库。
    请问,何解?
    2009年4月20日 4:55

答案

  • 我解决了

    iis管理器 aps.net全局配置中,连接字符管理串中,连接参数
    安装vs2008时,默认是sqlexpress,而我用的是sql server,更改正确参数即可。
    身份验证中要启用角色管理

    2009年4月22日 8:24

全部回复

  • 检查数据库连接看能否正确连上。也就是数据库设置,防火墙设置,连接字符串写法
    孟宪会
    2009年4月20日 6:40
    版主
  • 可以连接数据库的
    2009年4月20日 7:07
  • web.config里设置roleManager节点了吗
    孟宪会
    2009年4月20日 7:44
    版主
  • http://msdn.microsoft.com/zh-cn/library/879kf95c.aspx
    我按照此篇文档,进行到
    在使用 ASP.NET 成员资格之前,必须配置应用程序以启用成员资格和设置用户。可以使用网站管理工具,该工具提供了一个用于配置设置的类似向导的界面。完成安装向导之后,在项目的 App_Data 文件夹中创建一个名为 ASPNETDB.MDF 的 SQL Server 数据库。

    已使用aspnet_regsql新建数据库,但app_data中并未见aspnetdb

    1. “网站”菜单上单击“ASP.NET 配置”

    2. 选择“安全”选项卡,系统报如上错误。

      并未设置rolemanager

      谢谢

    2009年4月20日 8:14
  • <connectionStrings>
      <add name="连接名字" connectionString="server=.;uid=sa;pwd=;database=dbName"/>
     </connectionStrings>
    以下在system.web配置节中
    <membership defaultProvider="AspNetSqlMembershipProvider" userIsOnlineTimeWindow="15" hashAlgorithmType="">
       <providers>
        <clear/>
        <add connectionStringName="连接名字" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="应用名字" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression="" name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
       </providers>
      </membership>
      <roleManager enabled="true" cacheRolesInCookie="true">
       <providers>
        <clear/>
        <add connectionStringName="连接名字" applicationName="应用名字" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
       </providers>
      </roleManager>
    2009年4月20日 9:30
  • 你好,aspnet_regsql没有对app_data中的aspnetdb产生任何变化,你在注册aspnet_regsql忘记选择数据库了,而是默认了数据库。
    启动ASP.NET 配置 是检测到你已经有了aspnetdb就不会帮你产生新的aspnetdb文件了。
    jon.valett@gmail.com
    2009年4月20日 9:35
    版主
  • 还是没有搞定,先放放,继续其他的
    谢谢各位
    2009年4月21日 8:29
  • 我解决了

    iis管理器 aps.net全局配置中,连接字符管理串中,连接参数
    安装vs2008时,默认是sqlexpress,而我用的是sql server,更改正确参数即可。
    身份验证中要启用角色管理

    2009年4月22日 8:24